# CVE-2025-64481: Open redirect endpoint in Datasette

> Attackers can redirect users to malicious sites via crafted URLs in Datasette, potentially facilitating phishing attacks.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2025
- **Updated:** 26 Dec 2025
- **Also known as:** GHSA-w832-gg5g-x44m, PYSEC-2025-73

## What is CVE-2025-64481?

CVE-2025-64481 is a low-severity vulnerability in simonw datasette, published on 7 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Datasette is an open source multi-tool for exploring and publishing data. In versions 0.65.1 and below and 1.0a0 through 1.0a19, deployed instances of Datasette include an open redirect vulnerability. Hits to the path //example.com/foo/bar/ (the trailing slash is required) will redirect the user to https://example.com/foo/bar. This problem has been patched in both Datasette 0.65.2 and 1.0a21. To workaround this issue, if Datasette is running behind a proxy, that proxy could be configured to replace // with / in incoming request URLs.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-64481?

5 open source packages ship an affected version, including datasette.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `datasette` | PyPI | All versions | None |
| `datasette` | PyPI | All versions | 0.65.2 |
| `datasette` | PyPI | All versions | 0.65.2 |
| `datasette` | PyPI | From 1.0a0 | 1.0a21 |
| `datasette` | PyPI | From 1.0a0 | 1.0a21 |

## How do I fix CVE-2025-64481?

Upgrade datasette to a fixed version for your release line: 0.65.2 or 1.0a21.

## Is CVE-2025-64481 being exploited?

There is no known exploitation of CVE-2025-64481 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64481 and fix it if it is affected.

What it is: CVE-2025-64481 is a low-severity vulnerability in simonw datasette, published on 7 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64481 in the wild and no public exploit code.

Affected packages and fixed versions:
- datasette (PyPI): affected all versions; no fix listed
- datasette (PyPI): affected all versions; fixed in 0.65.2
- datasette (PyPI): affected all versions; fixed in 0.65.2
- datasette (PyPI): affected from 1.0a0; fixed in 1.0a21
- datasette (PyPI): affected from 1.0a0; fixed in 1.0a21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64481/ (Markdown: https://insights.sbomify.com/CVE-2025-64481/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64481
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64481
- OSV: https://osv.dev/vulnerability/CVE-2025-64481

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64481/
Summaries are generated and may contain mistakes; the official description above is the record.
