# CVE-2025-64483: Wazuh API – Agent Configuration Has Improper Access Control in Agent Enrollment Endpoint


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Nov 2025
- **Updated:** 6 Feb 2026
- **Also known as:** GHSA-gwf3-8gm3-qrmj

## What is CVE-2025-64483?

CVE-2025-64483 is a medium-severity vulnerability in wazuh-dashboard-plugins, published on 21 Nov 2025. 

### Official description

Wazuh is a security detection, visibility, and compliance open source project. From version 4.9.0 to before 4.13.0, the Wazuh API – Agent Configuration in certain configurations allows authenticated users with read-only API roles to retrieve agent enrollment credentials through the /utils/configuration endpoint. These credentials can be used to register new agents within the same Wazuh tenant without requiring elevated permissions through the UI. This issue has been patched in version 4.13.0.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-64483?


## How do I fix CVE-2025-64483?

No fix has been published for CVE-2025-64483 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-64483 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64483 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64483 and fix it if it is affected.

What it is: CVE-2025-64483 is a medium-severity vulnerability in wazuh-dashboard-plugins, published on 21 Nov 2025. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64483 exists.

Affected product: wazuh-dashboard-plugins. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64483/ (Markdown: https://insights.sbomify.com/CVE-2025-64483/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64483
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64483
- OSV: https://osv.dev/vulnerability/CVE-2025-64483

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64483/
Summaries are generated and may contain mistakes; the official description above is the record.
