{"answers":{"affected":"5 open source packages ship an affected version, including github.com/oauth2-proxy/oauth2-proxy/v7, oauth2-proxy and github.com/oauth2-proxy/oauth2-proxy.","exploited":"There is no known exploitation of CVE-2025-64484 in the wild and no public exploit code.","fix":"Upgrade github.com/oauth2-proxy/oauth2-proxy/v7 to 7.13.0 or later.","what":"CVE-2025-64484 is a high-severity vulnerability in oauth2-proxy, published on 10 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64484 and fix it if it is affected.\n\nWhat it is: CVE-2025-64484 is a high-severity vulnerability in oauth2-proxy, published on 10 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-64484 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected all versions; fixed in 7.13.0\n- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected all versions; fixed in 7.13.0\n- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected all versions; fixed in 7.13.0\n- oauth2-proxy (Bitnami): affected all versions; fixed in 7.13.0\n- github.com/oauth2-proxy/oauth2-proxy (Go): affected all versions; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64484/ (Markdown: https://insights.sbomify.com/CVE-2025-64484/index.md)","id":"CVE-2025-64484","markdown":"https://insights.sbomify.com/CVE-2025-64484/index.md","name":"CVE-2025-64484","record":{"aliases":["BIT-oauth2-proxy-2025-64484","GHSA-vjrc-mh2v-45x6","GO-2025-4113","MINI-5375-w6xw-hhcf","MINI-qqjw-h9g5-7vvx"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OAuth2 reverse proxy","requires_auth":"low_privilege","summary":"Authenticated users can bypass header filtering in OAuth2-Proxy by using underscores, potentially escalating privileges in upstream applications.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-644","name":"Improper Neutralization of HTTP Headers for Scripting Syntax"}],"description":"OAuth2-Proxy is an open-source tool that can act as either a standalone reverse proxy or a middleware component integrated into existing reverse proxy or load balancer setups. In versions prior to 7.13.0, all deployments of OAuth2 Proxy in front of applications that normalize underscores to dashes in HTTP headers (e.g., WSGI-based frameworks such as Django, Flask, FastAPI, and PHP applications). Authenticated users can inject underscore variants of X-Forwarded-* headers that bypass the proxy’s filtering logic, potentially escalating privileges in the upstream app. OAuth2 Proxy authentication/authorization itself is not compromised. The problem has been patched with v7.13.0. By default all specified headers will now be normalized, meaning that both capitalization and the use of underscores (_) versus dashes (-) will be ignored when matching headers to be stripped. For example, both `X-Forwarded-For` and `X_Forwarded-for` will now be treated as equivalent and stripped away. For those who have a rational that requires keeping a similar looking header and not stripping it, the maintainers introduced a new configuration field for Headers managed through the AlphaConfig called `InsecureSkipHeaderNormalization`. As a workaround, ensure filtering and processing logic in upstream services don't treat underscores and hyphens in Headers the same way.","ecosystems":["Bitnami","Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OAuth2-Proxy vulnerable to header smuggling via underscore, leading to potential privilege escalation","id":"CVE-2025-64484","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":5,"n_references":5,"next":{"headline":"CVAT: Mounted share file overwrite via crafted request","id":"CVE-2025-64485"},"packages":[{"ecosystem":"Bitnami","fixed":["7.13.0"],"introduced":["0"],"last_affected":[],"package":"oauth2-proxy","purl":"pkg:bitnami/oauth2-proxy","source":"BIT-oauth2-proxy-2025-64484"},{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/oauth2-proxy/oauth2-proxy","purl":"pkg:golang/github.com/oauth2-proxy/oauth2-proxy","source":"GO-2025-4113"},{"ecosystem":"Go","fixed":["7.13.0"],"introduced":["0"],"last_affected":[],"package":"github.com/oauth2-proxy/oauth2-proxy/v7","purl":null,"source":"GHSA-vjrc-mh2v-45x6"},{"ecosystem":"Go","fixed":["7.13.0"],"introduced":["0"],"last_affected":[],"package":"github.com/oauth2-proxy/oauth2-proxy/v7","purl":"pkg:golang/github.com/oauth2-proxy/oauth2-proxy/v7","source":"GHSA-vjrc-mh2v-45x6"},{"ecosystem":"Go","fixed":["7.13.0"],"introduced":["0"],"last_affected":[],"package":"github.com/oauth2-proxy/oauth2-proxy/v7","purl":"pkg:golang/github.com/oauth2-proxy/oauth2-proxy/v7","source":"GO-2025-4113"}],"prev":{"headline":"Wazuh API – Agent Configuration Has Improper Access Control in Agent Enrollment Endpoint","id":"CVE-2025-64483"},"products":["oauth2-proxy"],"published":"2025-11-10","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-14","vendors":["oauth2-proxy"]},"summary":"Authenticated users can bypass header filtering in OAuth2-Proxy by using underscores, potentially escalating privileges in upstream applications.","url":"https://insights.sbomify.com/CVE-2025-64484/"}