# CVE-2025-64484: OAuth2-Proxy vulnerable to header smuggling via underscore, leading to potential privilege escalation

> Authenticated users can bypass header filtering in OAuth2-Proxy by using underscores, potentially escalating privileges in upstream applications.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2025
- **Updated:** 14 Nov 2025
- **Also known as:** BIT-oauth2-proxy-2025-64484, GHSA-vjrc-mh2v-45x6, GO-2025-4113, MINI-5375-w6xw-hhcf, MINI-qqjw-h9g5-7vvx

## What is CVE-2025-64484?

CVE-2025-64484 is a high-severity vulnerability in oauth2-proxy, published on 10 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OAuth2-Proxy is an open-source tool that can act as either a standalone reverse proxy or a middleware component integrated into existing reverse proxy or load balancer setups. In versions prior to 7.13.0, all deployments of OAuth2 Proxy in front of applications that normalize underscores to dashes in HTTP headers (e.g., WSGI-based frameworks such as Django, Flask, FastAPI, and PHP applications). Authenticated users can inject underscore variants of X-Forwarded-* headers that bypass the proxy’s filtering logic, potentially escalating privileges in the upstream app. OAuth2 Proxy authentication/authorization itself is not compromised. The problem has been patched with v7.13.0. By default all specified headers will now be normalized, meaning that both capitalization and the use of underscores (_) versus dashes (-) will be ignored when matching headers to be stripped. For example, both `X-Forwarded-For` and `X_Forwarded-for` will now be treated as equivalent and stripped away. For those who have a rational that requires keeping a similar looking header and not stripping it, the maintainers introduced a new configuration field for Headers managed through the AlphaConfig called `InsecureSkipHeaderNormalization`. As a workaround, ensure filtering and processing logic in upstream services don't treat underscores and hyphens in Headers the same way.

Weakness: CWE-644 (Improper Neutralization of HTTP Headers for Scripting Syntax)

## Which versions are affected by CVE-2025-64484?

5 open source packages ship an affected version, including github.com/oauth2-proxy/oauth2-proxy/v7, oauth2-proxy and github.com/oauth2-proxy/oauth2-proxy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/oauth2-proxy/oauth2-proxy/v7` | Go | All versions | 7.13.0 |
| `github.com/oauth2-proxy/oauth2-proxy/v7` | Go | All versions | 7.13.0 |
| `github.com/oauth2-proxy/oauth2-proxy/v7` | Go | All versions | 7.13.0 |
| `oauth2-proxy` | Bitnami | All versions | 7.13.0 |
| `github.com/oauth2-proxy/oauth2-proxy` | Go | All versions | None |

## How do I fix CVE-2025-64484?

Upgrade github.com/oauth2-proxy/oauth2-proxy/v7 to 7.13.0 or later.

## Is CVE-2025-64484 being exploited?

There is no known exploitation of CVE-2025-64484 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64484 and fix it if it is affected.

What it is: CVE-2025-64484 is a high-severity vulnerability in oauth2-proxy, published on 10 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64484 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected all versions; fixed in 7.13.0
- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected all versions; fixed in 7.13.0
- github.com/oauth2-proxy/oauth2-proxy/v7 (Go): affected all versions; fixed in 7.13.0
- oauth2-proxy (Bitnami): affected all versions; fixed in 7.13.0
- github.com/oauth2-proxy/oauth2-proxy (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64484/ (Markdown: https://insights.sbomify.com/CVE-2025-64484/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64484
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64484
- OSV: https://osv.dev/vulnerability/CVE-2025-64484

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64484/
Summaries are generated and may contain mistakes; the official description above is the record.
