# CVE-2025-64485: CVAT: Mounted share file overwrite via crafted request

> A malicious user can overwrite files on mounted shares or fill disk space in the import worker container via crafted requests.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Nov 2025
- **Updated:** 10 Nov 2025
- **Also known as:** GHSA-x396-w86c-gf6w

## What is CVE-2025-64485?

CVE-2025-64485 is a medium-severity path traversal vulnerability in cvat-ai cvat, published on 7 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CVAT is an open source interactive video and image annotation tool for computer vision. In versions 2.4.0 through 2.48.1, a malicious CVAT user with at least the User global role may create files in the root of the mounted file share, or overwrite existing files. If no file share is mounted, the user will be able to create files in the share directory of the import worker container, potentially filling up disk space. This issue is fixed in version 2.49.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-64485?


## How do I fix CVE-2025-64485?

No fix has been published for CVE-2025-64485 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-64485 being exploited?

There is no known exploitation of CVE-2025-64485 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64485 and fix it if it is affected.

What it is: CVE-2025-64485 is a medium-severity path traversal vulnerability in cvat-ai cvat, published on 7 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64485 in the wild and no public exploit code.

Affected product: cvat-ai cvat. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64485/ (Markdown: https://insights.sbomify.com/CVE-2025-64485/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64485
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64485
- OSV: https://osv.dev/vulnerability/CVE-2025-64485

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64485/
Summaries are generated and may contain mistakes; the official description above is the record.
