# CVE-2025-64486: calibre is vulnerable to arbitrary code execution when opening FB2 files

> Attackers can achieve arbitrary code execution by tricking users into opening malicious FB2 files in calibre due to improper filename validation.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Nov 2025
- **Updated:** 13 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-64486, GHSA-hpwq-c98h-xp8g, UBUNTU-CVE-2025-64486

## What is CVE-2025-64486?

CVE-2025-64486 is a critical path traversal vulnerability in kovidgoyal calibre, published on 7 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

calibre is an e-book manager. In versions 8.13.0 and prior, calibre does not validate filenames when handling binary assets in FB2 files, allowing an attacker to write arbitrary files on the filesystem when viewing or converting a malicious FictionBook file. This can be leveraged to achieve arbitrary code execution. This issue is fixed in version 8.14.0.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2025-64486?


## How do I fix CVE-2025-64486?

Upgrade to a fixed version.

## Is CVE-2025-64486 being exploited?

There is no known exploitation of CVE-2025-64486 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64486 and fix it if it is affected.

What it is: CVE-2025-64486 is a critical path traversal vulnerability in kovidgoyal calibre, published on 7 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-64486 in the wild and no public exploit code.

Affected product: kovidgoyal calibre. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64486/ (Markdown: https://insights.sbomify.com/CVE-2025-64486/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64486
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64486
- OSV: https://osv.dev/vulnerability/CVE-2025-64486

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64486/
Summaries are generated and may contain mistakes; the official description above is the record.
