CVE-2025-64494 Soft Serve does not sanitize ANSI escape sequences in user input

Medium 4.6 Published Updated

Attackers can inject ANSI escape sequences into user input to display fake alerts or manipulate terminal output in Soft Serve Git server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-64494?

CVE-2025-64494 is a medium-severity vulnerability in charmbracelet soft-serve, published on 8 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Soft Serve is a self-hostable Git server for the command line. In versions prior to 0.10.0, there are several places where the user can insert data (e.g. names) and ANSI escape sequences are not being removed, which can then be used, for example, to show fake alerts. In the same token, git messages, when printed, are also not being sanitized. This issue is fixed in version 0.10.0.

Weakness: CWE-150

Which versions are affected by CVE-2025-64494?

3 open source packages ship an affected version, including github.com/charmbracelet/soft-serve.

PackageAffectedFixed in
github.com/charmbracelet/soft-serve GoAll versions0.11.0
github.com/charmbracelet/soft-serve GoAll versions0.11.0
github.com/charmbracelet/soft-serve GoAll versions0.11.0

How do I fix CVE-2025-64494?

Upgrade github.com/charmbracelet/soft-serve to 0.11.0 or later.

Is CVE-2025-64494 being exploited?

There is no known exploitation of CVE-2025-64494 in the wild and no public exploit code.

Sources

Also known as GHSA-fv2r-r8mp-pg48, GO-2025-4106.

Is CVE-2025-64494 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free