{"answers":{"affected":"3 open source packages ship an affected version, including github.com/charmbracelet/soft-serve.","exploited":"There is no known exploitation of CVE-2025-64494 in the wild and no public exploit code.","fix":"Upgrade github.com/charmbracelet/soft-serve to 0.11.0 or later.","what":"CVE-2025-64494 is a medium-severity vulnerability in charmbracelet soft-serve, published on 8 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-64494 and fix it if it is affected.\n\nWhat it is: CVE-2025-64494 is a medium-severity vulnerability in charmbracelet soft-serve, published on 8 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-64494 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.11.0\n- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.11.0\n- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64494/ (Markdown: https://insights.sbomify.com/CVE-2025-64494/index.md)","id":"CVE-2025-64494","markdown":"https://insights.sbomify.com/CVE-2025-64494/index.md","name":"CVE-2025-64494","record":{"aliases":["GHSA-fv2r-r8mp-pg48","GO-2025-4106"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Git server","requires_auth":"low_privilege","summary":"Attackers can inject ANSI escape sequences into user input to display fake alerts or manipulate terminal output in Soft Serve Git server.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-150","name":"Improper Neutralization of Escape, Meta, or Control Sequences"}],"description":"Soft Serve is a self-hostable Git server for the command line. In versions prior to 0.10.0, there are several places where the user can insert data (e.g. names) and ANSI escape sequences are not being removed, which can then be used, for example, to show fake alerts. In the same token, git messages, when printed, are also not being sanitized. This issue is fixed in version 0.10.0.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Soft Serve does not sanitize ANSI escape sequences in user input","id":"CVE-2025-64494","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"other","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Open WebUI vulnerable to Stored DOM XSS via prompts when 'Insert Prompt as Rich Text' is enabled resulting in ATO/RCE","id":"CVE-2025-64495"},"packages":[{"ecosystem":"Go","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"github.com/charmbracelet/soft-serve","purl":null,"source":"GHSA-fv2r-r8mp-pg48"},{"ecosystem":"Go","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"github.com/charmbracelet/soft-serve","purl":"pkg:golang/github.com/charmbracelet/soft-serve","source":"GHSA-fv2r-r8mp-pg48"},{"ecosystem":"Go","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"github.com/charmbracelet/soft-serve","purl":"pkg:golang/github.com/charmbracelet/soft-serve","source":"GO-2025-4106"}],"prev":{"headline":"SuiteCRM is Vulnerable to Authenticated Blind SQL Injection via GraphQL","id":"CVE-2025-64493"},"products":["soft-serve"],"published":"2025-11-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-10","vendors":["charmbracelet"]},"summary":"Attackers can inject ANSI escape sequences into user input to display fake alerts or manipulate terminal output in Soft Serve Git server.","url":"https://insights.sbomify.com/CVE-2025-64494/"}