# CVE-2025-64494: Soft Serve does not sanitize ANSI escape sequences in user input

> Attackers can inject ANSI escape sequences into user input to display fake alerts or manipulate terminal output in Soft Serve Git server.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Nov 2025
- **Updated:** 10 Nov 2025
- **Also known as:** GHSA-fv2r-r8mp-pg48, GO-2025-4106

## What is CVE-2025-64494?

CVE-2025-64494 is a medium-severity vulnerability in charmbracelet soft-serve, published on 8 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Soft Serve is a self-hostable Git server for the command line. In versions prior to 0.10.0, there are several places where the user can insert data (e.g. names) and ANSI escape sequences are not being removed, which can then be used, for example, to show fake alerts. In the same token, git messages, when printed, are also not being sanitized. This issue is fixed in version 0.10.0.

Weakness: CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences)

## Which versions are affected by CVE-2025-64494?

3 open source packages ship an affected version, including github.com/charmbracelet/soft-serve.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.11.0 |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.11.0 |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.11.0 |

## How do I fix CVE-2025-64494?

Upgrade github.com/charmbracelet/soft-serve to 0.11.0 or later.

## Is CVE-2025-64494 being exploited?

There is no known exploitation of CVE-2025-64494 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64494 and fix it if it is affected.

What it is: CVE-2025-64494 is a medium-severity vulnerability in charmbracelet soft-serve, published on 8 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-64494 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.11.0
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.11.0
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64494/ (Markdown: https://insights.sbomify.com/CVE-2025-64494/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64494
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64494
- OSV: https://osv.dev/vulnerability/CVE-2025-64494

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64494/
Summaries are generated and may contain mistakes; the official description above is the record.
