# CVE-2025-64495: Open WebUI vulnerable to Stored DOM XSS via prompts when 'Insert Prompt as Rich Text' is enabled resulting in ATO/RCE

> Stored DOM XSS in Open WebUI allows attackers to execute arbitrary code or take over accounts via malicious prompts when rich text insertion is enabled.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Nov 2025
- **Updated:** 10 Nov 2025
- **Also known as:** GHSA-w7xj-8fx7-wfch, PYSEC-2026-1741

## What is CVE-2025-64495?

CVE-2025-64495 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 8 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. In versions 0.6.34 and below, the functionality that inserts custom prompts into the chat window is vulnerable to DOM XSS when 'Insert Prompt as Rich Text' is enabled, since the prompt body is assigned to the DOM sink .innerHtml without sanitisation. Any user with permissions to create prompts can abuse this to plant a payload that could be triggered by other users if they run the corresponding / command to insert the prompt. This issue is fixed in version 0.6.35.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-64495?

5 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.6.35 |
| `open-webui` | PyPI | All versions | 0.6.35 |
| `open-webui` | PyPI | All versions | 0.6.35 |
| `open-webui` | npm | All versions | 0.6.35 |
| `open-webui` | npm | All versions | 0.6.35 |

Products: Openwebui Open Webui.

## How do I fix CVE-2025-64495?

Upgrade open-webui to 0.6.35 or later.

## Is CVE-2025-64495 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64495 exists.

Public exploit code:

- Open WebUI vulnerable to Stored DOM XSS via prompts when 'Insert Prompt as Rich Text' is enabled resulting in ATO/RCE (github_poc): https://github.com/AlphabugX/CVE-2025-64495-POC

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64495 and fix it if it is affected.

What it is: CVE-2025-64495 is a high-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 8 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64495 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.6.35
- open-webui (PyPI): affected all versions; fixed in 0.6.35
- open-webui (PyPI): affected all versions; fixed in 0.6.35
- open-webui (npm): affected all versions; fixed in 0.6.35
- open-webui (npm): affected all versions; fixed in 0.6.35

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64495/ (Markdown: https://insights.sbomify.com/CVE-2025-64495/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64495
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64495
- OSV: https://osv.dev/vulnerability/CVE-2025-64495

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64495/
Summaries are generated and may contain mistakes; the official description above is the record.
