# CVE-2025-64496: Open WebUI Affected by an External Model Server (Direct Connections) Code Injection via SSE Events

> Malicious model servers can inject JavaScript via SSE events in Open WebUI, leading to account takeover and potential backend code execution.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Nov 2025
- **Updated:** 13 Nov 2025
- **Also known as:** GHSA-cm35-v4vp-5xvx, PYSEC-2026-1729

## What is CVE-2025-64496?

CVE-2025-64496 is a high-severity code injection vulnerability in Openwebui Open Webui, published on 8 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Versions 0.6.224 and prior contain a code injection vulnerability in the Direct Connections feature that allows malicious external model servers to execute arbitrary JavaScript in victim browsers via Server-Sent Event (SSE) execute events. This leads to authentication token theft, complete account takeover, and when chained with the Functions API, enables remote code execution on the backend server. The attack requires the victim to enable Direct Connections (disabled by default) and add the attacker's malicious model URL, achievable through social engineering of the admin and subsequent users. This issue is fixed in version 0.6.35.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code), CWE-830 (Inclusion of Web Functionality from an Untrusted Source), CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-501 (Trust Boundary Violation)

## Which versions are affected by CVE-2025-64496?

5 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.6.35 |
| `open-webui` | PyPI | All versions | 0.6.35 |
| `open-webui` | PyPI | All versions | 0.6.35 |
| `open-webui` | npm | All versions | 0.6.35 |
| `open-webui` | npm | All versions | 0.6.35 |

Products: Openwebui Open Webui.

## How do I fix CVE-2025-64496?

Upgrade open-webui to 0.6.35 or later.

## Is CVE-2025-64496 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64496 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64496 and fix it if it is affected.

What it is: CVE-2025-64496 is a high-severity code injection vulnerability in Openwebui Open Webui, published on 8 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64496 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.6.35
- open-webui (PyPI): affected all versions; fixed in 0.6.35
- open-webui (PyPI): affected all versions; fixed in 0.6.35
- open-webui (npm): affected all versions; fixed in 0.6.35
- open-webui (npm): affected all versions; fixed in 0.6.35

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64496/ (Markdown: https://insights.sbomify.com/CVE-2025-64496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64496
- OSV: https://osv.dev/vulnerability/CVE-2025-64496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64496/
Summaries are generated and may contain mistakes; the official description above is the record.
