{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-64499 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-64499 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-64499 is a medium-severity vulnerability in Enalean Tuleap, published on 8 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-64499 and fix it if it is affected.\n\nWhat it is: CVE-2025-64499 is a medium-severity vulnerability in Enalean Tuleap, published on 8 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-64499 in the wild and no public exploit code.\n\nAffected product: Enalean Tuleap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64499/ (Markdown: https://insights.sbomify.com/CVE-2025-64499/index.md)","id":"CVE-2025-64499","markdown":"https://insights.sbomify.com/CVE-2025-64499/index.md","name":"CVE-2025-64499","record":{"aliases":["GHSA-9h47-jg7r-ww7x"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Tuleap project management","requires_auth":"low_privilege","summary":"Attackers can force users to create, edit, or remove plans via CSRF in Tuleap's planning API, requiring an upgrade to secure the application.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"tuleap","vendor":"enalean"}],"cvss":{"score":4.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Tuleap is a free and open source suite for management of software development and collaboration. Tuleap Community Editon versions prior to 17.0.99.1762456922 and Tuleap Enterprise Edition versions prior to 17.0-2, 16.13-7 and 16.12-10 are vulnerable to CSRF attacks through planning management API. Attackers have access to create, edit or remove plans. This issue is fixed in Tuleap Community Edition version 17.0.99.1762456922 and Tuleap Enterprise Edtion versions 17.0-2, 16.13-7 and 16.12-10.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Tuleap is missing CSRF protections for its planning management API","id":"CVE-2025-64499","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"enalean:tuleap","products":["enalean:tuleap"],"type":"csrf","year":"2025"},"n_packages":0,"n_references":4,"next":{"headline":"Symfony's incorrect parsing of PATH_INFO can lead to limited authorization bypass","id":"CVE-2025-64500"},"packages":[],"prev":{"headline":"Tuleap has a Cross-Site Request Forgery (CSRF) vulnerability","id":"CVE-2025-64498"},"products":["tuleap"],"published":"2025-12-08","related":[{"cvss_score":9.8,"headline":"Business logic in n/a","id":"CVE-2018-17298","kev_date_added":null,"published":"2018-09-21"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2018-7538","kev_date_added":null,"published":"2018-03-12"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2014-7178","kev_date_added":null,"published":"2014-11-28"},{"cvss_score":8.8,"headline":"SQL injection in Tuleap","id":"CVE-2021-43806","kev_date_added":null,"published":"2021-12-15"},{"cvss_score":8.8,"headline":"SQL injection in the \"SVN core\" commits browser","id":"CVE-2021-41154","kev_date_added":null,"published":"2021-10-18"},{"cvss_score":8.8,"headline":"SQL injection in CVS revisions browser","id":"CVE-2021-41155","kev_date_added":null,"published":"2021-10-18"},{"cvss_score":8.8,"headline":"The update of the CI job targeted by a widget is vulnerable to blind SQL injections","id":"CVE-2021-41148","kev_date_added":null,"published":"2021-10-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-09","vendors":["Enalean"]},"summary":"Attackers can force users to create, edit, or remove plans via CSRF in Tuleap's planning API, requiring an upgrade to secure the application.","url":"https://insights.sbomify.com/CVE-2025-64499/"}