# CVE-2025-64500: Symfony's incorrect parsing of PATH_INFO can lead to limited authorization bypass

> Attackers can bypass access control rules in Symfony applications by exploiting improper PATH_INFO parsing that violates path prefix assumptions.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Nov 2025
- **Updated:** 13 Nov 2025
- **Also known as:** CLSA-2025-1766451449, CLSA-2026-1768265576, DEBIAN-CVE-2025-64500, GHSA-3rg7-wf37-54rm, UBUNTU-CVE-2025-64500

## What is CVE-2025-64500?

CVE-2025-64500 is a high-severity authentication bypass vulnerability in Sensiolabs Symfony, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Symfony's HttpFoundation component defines an object-oriented layer for the HTTP specification. Starting in version 2.0.0 and prior to version 5.4.50, 6.4.29, and 7.3.7, the `Request` class improperly interprets some `PATH_INFO` in a way that leads to representing some URLs with a path that doesn't start with a `/`. This can allow bypassing some access control rules that are built with this `/`-prefix assumption. Starting in versions 5.4.50, 6.4.29, and 7.3.7, the `Request` class now ensures that URL paths always start with a `/`.

Weakness: CWE-647 (Use of Non-Canonical URL Paths for Authorization Decisions)

## Which versions are affected by CVE-2025-64500?

12 open source packages ship an affected version, including symfony/http-foundation and symfony/symfony. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/http-foundation` | Packagist | All versions | 5.4.50 |
| `symfony/http-foundation` | Packagist | All versions | 5.4.50 |
| `symfony/http-foundation` | Packagist | From 6.0.0 | 6.4.29 |
| `symfony/http-foundation` | Packagist | From 6.0.0 | 6.4.29 |
| `symfony/http-foundation` | Packagist | From 7.0.0 | 7.3.7 |
| `symfony/http-foundation` | Packagist | From 7.0.0 | 7.3.7 |
| `symfony/symfony` | Packagist | From 2.0.0 | 5.4.50 |
| `symfony/symfony` | Packagist | From 2.0.0 | 5.4.50 |
| `symfony/symfony` | Packagist | From 6.0.0 | 6.4.29 |
| `symfony/symfony` | Packagist | From 6.0.0 | 6.4.29 |
| `symfony/symfony` | Packagist | From 7.0.0 | 7.3.7 |
| `symfony/symfony` | Packagist | From 7.0.0 | 7.3.7 |

Products: Sensiolabs Httpfoundation, Sensiolabs Symfony.

## How do I fix CVE-2025-64500?

Upgrade symfony/http-foundation to a fixed version for your release line: 5.4.50, 6.4.29 or 7.3.7.

## Is CVE-2025-64500 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64500 exists.

Public exploit code:

- Symfony HttpFoundation - Access Control Bypass via PATH_INFO (nuclei): http/cves/2025/CVE-2025-64500.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64500 and fix it if it is affected.

What it is: CVE-2025-64500 is a high-severity authentication bypass vulnerability in Sensiolabs Symfony, published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64500 exists.

Affected packages and fixed versions:
- symfony/http-foundation (Packagist): affected all versions; fixed in 5.4.50
- symfony/http-foundation (Packagist): affected all versions; fixed in 5.4.50
- symfony/http-foundation (Packagist): affected from 6.0.0; fixed in 6.4.29
- symfony/http-foundation (Packagist): affected from 6.0.0; fixed in 6.4.29
- symfony/http-foundation (Packagist): affected from 7.0.0; fixed in 7.3.7
- symfony/http-foundation (Packagist): affected from 7.0.0; fixed in 7.3.7
- symfony/symfony (Packagist): affected from 2.0.0; fixed in 5.4.50
- symfony/symfony (Packagist): affected from 2.0.0; fixed in 5.4.50
- symfony/symfony (Packagist): affected from 6.0.0; fixed in 6.4.29
- symfony/symfony (Packagist): affected from 6.0.0; fixed in 6.4.29
- symfony/symfony (Packagist): affected from 7.0.0; fixed in 7.3.7
- symfony/symfony (Packagist): affected from 7.0.0; fixed in 7.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64500/ (Markdown: https://insights.sbomify.com/CVE-2025-64500/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64500
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64500
- OSV: https://osv.dev/vulnerability/CVE-2025-64500

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64500/
Summaries are generated and may contain mistakes; the official description above is the record.
