# CVE-2025-64505: LIBPNG is vulnerable to a heap buffer overflow in `png_do_quantize` via malformed palette index

> An attacker can cause a heap buffer over-read in libpng by providing a malformed PNG file with invalid palette indices, potentially leading to crashes or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Nov 2025
- **Updated:** 25 Nov 2025
- **Also known as:** A-463980379, ALPINE-CVE-2025-64505, ASB-A-463980379, AZL-70763, AZL-70844, AZL-70859, AZL-70862, AZL-70865, AZL-70880, AZL-70894, AZL-70906, AZL-70909, AZL-70918, AZL-70969, BELL-CVE-2025-64505, CLSA-2025-1765288864, CLSA-2025-1765380269, CLSA-2025-1766135952, CLSA-2025-1766165929, CLSA-2026-1785493623, CLSA-2026-1785495654, DEBIAN-CVE-2025-64505, ECHO-1949-597a-9e78, GHSA-4952-h5wq-4m42, JLSEC-2025-328, MINI-5rgh-w6qx-pxvv, SUSE-SU-2025:4383-1, SUSE-SU-2025:4432-1, SUSE-SU-2026:0898-1, openSUSE-SU-2025:15797-1

## What is CVE-2025-64505?

CVE-2025-64505 is a medium-severity memory corruption vulnerability in Libpng Libpng, published on 24 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. Prior to version 1.6.51, a heap buffer over-read vulnerability exists in libpng's png_do_quantize function when processing PNG files with malformed palette indices. The vulnerability occurs when palette_lookup array bounds are not validated against externally-supplied image data, allowing an attacker to craft a PNG file with out-of-range palette indices that trigger out-of-bounds memory access. This issue has been patched in version 1.6.51.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-64505?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpng12` | SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 1.2.57-150000.4.3.1 |
| `libpng12` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 1.2.57-150000.4.3.1 |
| `libpng12` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 1.2.50-20.6.1 |
| `libpng15` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 1.5.22-10.7.1 |
| `libpng12` | openSUSE:Leap 15.6 | All versions | 1.2.57-150000.4.3.1 |
| `libpng12` | openSUSE:Tumbleweed | All versions | 1.2.59-4.1 |

Products: Libpng Libpng.

## How do I fix CVE-2025-64505?

Upgrade to a fixed version.

## Is CVE-2025-64505 being exploited?

There is no known exploitation of CVE-2025-64505 in the wild and no public exploit code.

## Other vulnerabilities in Libpng Libpng

- [CVE-2017-12652](https://insights.sbomify.com/CVE-2017-12652/): Denial of service in n/a (critical 9.8)
- [CVE-2018-14550](https://insights.sbomify.com/CVE-2018-14550/): Out-of-bounds write in libpng (high 8.8)
- [CVE-2026-25646](https://insights.sbomify.com/CVE-2026-25646/): LIBPNG has a heap buffer overflow in png_set_quantize (high 8.3)
- [CVE-2026-33636](https://insights.sbomify.com/CVE-2026-33636/): LIBPNG has ARM NEON Palette Expansion Out-of-Bounds Read on AArch64 (high 7.6)
- [CVE-2026-33416](https://insights.sbomify.com/CVE-2026-33416/): LIBPNG has use-after-free via pointer aliasing in `png_set_tRNS` and `png_set_PLTE` (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64505 and fix it if it is affected.

What it is: CVE-2025-64505 is a medium-severity memory corruption vulnerability in Libpng Libpng, published on 24 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-64505 in the wild and no public exploit code.

Affected product: Libpng Libpng. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64505/ (Markdown: https://insights.sbomify.com/CVE-2025-64505/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64505
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64505
- OSV: https://osv.dev/vulnerability/CVE-2025-64505

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64505/
Summaries are generated and may contain mistakes; the official description above is the record.
