# CVE-2025-64507: Incus vulnerable to local privilege escalation through custom storage volumes

> Local attackers can gain root privileges on the host by writing a setuid binary to a custom storage volume with shifted security properties.

- **Severity:** High 8.6 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2025
- **Updated:** 12 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-64507, DSA-6051-1, DSA-6057-1, GHSA-56mx-8g9f-5crf, GO-2025-4115, UBUNTU-CVE-2025-64507

## What is CVE-2025-64507?

CVE-2025-64507 is a high-severity vulnerability in lxc incus, published on 10 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Incus is a system container and virtual machine manager. An issue in versions prior to 6.0.6 and 6.19.0 affects any Incus user in an environment where an unprivileged user may have root access to a container with an attached custom storage volume that has the `security.shifted` property set to `true` as well as access to the host as an unprivileged user. The most common case for this would be systems using `incus-user` with the less privileged `incus` group to provide unprivileged users with an isolated restricted access to Incus. Such users may be able to create a custom storage volume with the necessary property (depending on kernel and filesystem support) and can then write a setuid binary from within the container which can be executed as an unprivileged user on the host to gain root privileges. A patch for this issue is expected in versions 6.0.6 and 6.19.0. As a workaround, permissions can be manually restricted until a patched version of Incus is deployed.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2025-64507?

4 open source packages ship an affected version, including github.com/lxc/incus/v6 and github.com/lxc/incus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v6` | Go | All versions | 6.19.0 |
| `github.com/lxc/incus/v6` | Go | All versions | 6.19.0 |
| `github.com/lxc/incus/v6` | Go | From 6.1.0 | None |
| `github.com/lxc/incus` | Go | All versions | None |

Products: Linuxcontainers Incus.

## How do I fix CVE-2025-64507?

Upgrade github.com/lxc/incus/v6 to 6.19.0 or later.

## Is CVE-2025-64507 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64507 exists.

## Other vulnerabilities in lxc incus

- [CVE-2026-33897](https://insights.sbomify.com/CVE-2026-33897/): Incus vulnerable to arbitrary file read and write through pongo templates (critical 10.0)
- [CVE-2026-33945](https://insights.sbomify.com/CVE-2026-33945/): Abitrary file write through systemd-creds option (critical 10.0)
- [CVE-2026-33898](https://insights.sbomify.com/CVE-2026-33898/): Local Incus UI web server vulnerable to nuthentication bypass (high 8.8)
- [CVE-2026-23953](https://insights.sbomify.com/CVE-2026-23953/): Incus container environment configuration newline injection (high 8.7)
- [CVE-2026-23954](https://insights.sbomify.com/CVE-2026-23954/): Incus container image templating arbitrary host file read and write (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64507 and fix it if it is affected.

What it is: CVE-2025-64507 is a high-severity vulnerability in lxc incus, published on 10 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64507 exists.

Affected packages and fixed versions:
- github.com/lxc/incus/v6 (Go): affected all versions; fixed in 6.19.0
- github.com/lxc/incus/v6 (Go): affected all versions; fixed in 6.19.0
- github.com/lxc/incus/v6 (Go): affected from 6.1.0; no fix listed
- github.com/lxc/incus (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64507/ (Markdown: https://insights.sbomify.com/CVE-2025-64507/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64507
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64507
- OSV: https://osv.dev/vulnerability/CVE-2025-64507

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64507/
Summaries are generated and may contain mistakes; the official description above is the record.
