{"answers":{"affected":"3 open source packages ship an affected version, including bugsink.","exploited":"There is no known exploitation of CVE-2025-64508 in the wild and no public exploit code.","fix":"Upgrade bugsink to 2.0.5 or later.","what":"CVE-2025-64508 is a high-severity denial of service vulnerability in bugsink, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64508 and fix it if it is affected.\n\nWhat it is: CVE-2025-64508 is a high-severity denial of service vulnerability in bugsink, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-64508 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bugsink (PyPI): affected all versions; fixed in 2.0.5\n- bugsink (PyPI): affected all versions; fixed in 2.0.5\n- bugsink (PyPI): affected all versions; fixed in 2.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64508/ (Markdown: https://insights.sbomify.com/CVE-2025-64508/index.md)","id":"CVE-2025-64508","markdown":"https://insights.sbomify.com/CVE-2025-64508/index.md","name":"CVE-2025-64508","record":{"aliases":["GHSA-fc2v-vcwj-269v","PYSEC-2026-1225"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Error tracking tool","requires_auth":"none","summary":"Attackers can cause denial of service in Bugsink by sending crafted Brotli streams that exhaust server memory during decompression.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Bugsink is a self-hosted error tracking tool. In versions prior to 2.0.5, brotli \"bombs\" (highly compressed brotli streams, such as many zeros) can be sent to the server. Since the server will attempt to decompress these streams before applying various maximums, this can lead to exhaustion of the available memory and thus a Denial of Service. This can be done if the `DSN` is known, which it is in many common setups (JavaScript, Mobile Apps). The issue is patched in Bugsink version `2.0.5`. The vulnerability is similar to, but distinct from, another brotli-related problem in Bugsink, GHSA-rrx3-2x4g-mq2h/CVE-2025-64509.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Bugsink vulnerable to unauthenticated remote DoS via crafted Brotli input","id":"CVE-2025-64508","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":8,"next":{"headline":"Bugsink vulnerable to unauthenticated remote DoS via crafted Brotli input (via CPU)","id":"CVE-2025-64509"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"bugsink","purl":null,"source":"GHSA-fc2v-vcwj-269v"},{"ecosystem":"PyPI","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"bugsink","purl":"pkg:pypi/bugsink","source":"GHSA-fc2v-vcwj-269v"},{"ecosystem":"PyPI","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"bugsink","purl":"pkg:pypi/bugsink","source":"PYSEC-2026-1225"}],"prev":{"headline":"Incus vulnerable to local privilege escalation through custom storage volumes","id":"CVE-2025-64507"},"products":["bugsink"],"published":"2025-11-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-12","vendors":["bugsink"]},"summary":"Attackers can cause denial of service in Bugsink by sending crafted Brotli streams that exhaust server memory during decompression.","url":"https://insights.sbomify.com/CVE-2025-64508/"}