# CVE-2025-64508: Bugsink vulnerable to unauthenticated remote DoS via crafted Brotli input

> Attackers can cause denial of service in Bugsink by sending crafted Brotli streams that exhaust server memory during decompression.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2025
- **Updated:** 12 Nov 2025
- **Also known as:** GHSA-fc2v-vcwj-269v, PYSEC-2026-1225

## What is CVE-2025-64508?

CVE-2025-64508 is a high-severity denial of service vulnerability in bugsink, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Bugsink is a self-hosted error tracking tool. In versions prior to 2.0.5, brotli "bombs" (highly compressed brotli streams, such as many zeros) can be sent to the server. Since the server will attempt to decompress these streams before applying various maximums, this can lead to exhaustion of the available memory and thus a Denial of Service. This can be done if the `DSN` is known, which it is in many common setups (JavaScript, Mobile Apps). The issue is patched in Bugsink version `2.0.5`. The vulnerability is similar to, but distinct from, another brotli-related problem in Bugsink, GHSA-rrx3-2x4g-mq2h/CVE-2025-64509.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-64508?

3 open source packages ship an affected version, including bugsink.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bugsink` | PyPI | All versions | 2.0.5 |
| `bugsink` | PyPI | All versions | 2.0.5 |
| `bugsink` | PyPI | All versions | 2.0.5 |

## How do I fix CVE-2025-64508?

Upgrade bugsink to 2.0.5 or later.

## Is CVE-2025-64508 being exploited?

There is no known exploitation of CVE-2025-64508 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64508 and fix it if it is affected.

What it is: CVE-2025-64508 is a high-severity denial of service vulnerability in bugsink, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64508 in the wild and no public exploit code.

Affected packages and fixed versions:
- bugsink (PyPI): affected all versions; fixed in 2.0.5
- bugsink (PyPI): affected all versions; fixed in 2.0.5
- bugsink (PyPI): affected all versions; fixed in 2.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64508/ (Markdown: https://insights.sbomify.com/CVE-2025-64508/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64508
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64508
- OSV: https://osv.dev/vulnerability/CVE-2025-64508

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64508/
Summaries are generated and may contain mistakes; the official description above is the record.
