{"answers":{"affected":"3 open source packages ship an affected version, including bugsink.","exploited":"There is no known exploitation of CVE-2025-64509 in the wild and no public exploit code.","fix":"Upgrade bugsink to 2.0.6 or later.","what":"CVE-2025-64509 is a high-severity denial of service vulnerability in bugsink, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64509 and fix it if it is affected.\n\nWhat it is: CVE-2025-64509 is a high-severity denial of service vulnerability in bugsink, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-64509 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bugsink (PyPI): affected all versions; fixed in 2.0.6\n- bugsink (PyPI): affected all versions; fixed in 2.0.6\n- bugsink (PyPI): affected all versions; fixed in 2.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64509/ (Markdown: https://insights.sbomify.com/CVE-2025-64509/index.md)","id":"CVE-2025-64509","markdown":"https://insights.sbomify.com/CVE-2025-64509/index.md","name":"CVE-2025-64509","record":{"aliases":["GHSA-rrx3-2x4g-mq2h","PYSEC-2026-1227"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Bugsink error tracking","requires_auth":"none","summary":"An attacker can cause denial of service in Bugsink by sending crafted Brotli input, consuming excessive CPU resources.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Bugsink is a self-hosted error tracking tool. In versions prior to 2.0.6, a specially crafted Brotli-compressed envelope can cause Bugsink to spend excessive CPU time in decompression, leading to denial of service. This can be done if the DSN is known, which it is in many common setups (JavaScript, Mobile Apps). The issue is patched in Bugsink 2.0.6. The vulnerability is similar to, but distinct from, another brotli-related problem in Bugsink, GHSA-fc2v-vcwj-269v/CVE-2025-64508.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Bugsink vulnerable to unauthenticated remote DoS via crafted Brotli input (via CPU)","id":"CVE-2025-64509","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"MaxKB has SSRF in sandbox","id":"CVE-2025-64511"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.6"],"introduced":["0"],"last_affected":[],"package":"bugsink","purl":null,"source":"GHSA-rrx3-2x4g-mq2h"},{"ecosystem":"PyPI","fixed":["2.0.6"],"introduced":["0"],"last_affected":[],"package":"bugsink","purl":"pkg:pypi/bugsink","source":"GHSA-rrx3-2x4g-mq2h"},{"ecosystem":"PyPI","fixed":["2.0.6"],"introduced":["0"],"last_affected":[],"package":"bugsink","purl":"pkg:pypi/bugsink","source":"PYSEC-2026-1227"}],"prev":{"headline":"Bugsink vulnerable to unauthenticated remote DoS via crafted Brotli input","id":"CVE-2025-64508"},"products":["bugsink"],"published":"2025-11-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-12","vendors":["bugsink"]},"summary":"An attacker can cause denial of service in Bugsink by sending crafted Brotli input, consuming excessive CPU resources.","url":"https://insights.sbomify.com/CVE-2025-64509/"}