# CVE-2025-64513: Milvus Proxy has Critical Authentication Bypass Vulnerability

> Unauthenticated attackers can bypass authentication in Milvus Proxy to gain full administrative access, allowing them to read, modify, or delete data and manage the cluster.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2025
- **Updated:** 12 Nov 2025
- **Also known as:** BIT-milvus-2025-64513, GHSA-mhjq-8c7m-3f7p, GO-2025-4114

## What is CVE-2025-64513?

CVE-2025-64513 is a critical authentication bypass vulnerability in milvus-io milvus, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Milvus is an open-source vector database built for generative AI applications. An unauthenticated attacker can exploit a vulnerability in versions prior to 2.4.24, 2.5.21, and 2.6.5 to bypass all authentication mechanisms in the Milvus Proxy component, gaining full administrative access to the Milvus cluster. This grants the attacker the ability to read, modify, or delete data, and to perform privileged administrative operations such as database or collection management. This issue has been fixed in Milvus 2.4.24, 2.5.21, and 2.6.5. If immediate upgrade is not possible, a temporary mitigation can be applied by removing the sourceID header from all incoming requests at the gateway, API gateway, or load balancer level before they reach the Milvus Proxy. This prevents attackers from exploiting the authentication bypass behavior.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-64513?

10 open source packages ship an affected version, including github.com/milvus-io/milvus and milvus.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/milvus-io/milvus` | Go | All versions | 0.10.3-0.20251107071934-6102f001a971 |
| `github.com/milvus-io/milvus` | Go | All versions | 0.10.3-0.20251107071934-6102f001a971 |
| `github.com/milvus-io/milvus` | Go | All versions | 0.10.3-0.20251107071934-6102f001a971 |
| `github.com/milvus-io/milvus` | Go | From 0.10.4 | 2.4.24 |
| `github.com/milvus-io/milvus` | Go | From 0.10.4 | 2.4.24 |
| `github.com/milvus-io/milvus` | Go | From 2.5.0 | 2.5.21 |
| `github.com/milvus-io/milvus` | Go | From 2.5.0 | 2.5.21 |
| `github.com/milvus-io/milvus` | Go | From 2.6.0 | 2.6.5 |
| `github.com/milvus-io/milvus` | Go | From 2.6.0 | 2.6.5 |
| `milvus` | Bitnami | All versions | 2.4.24, 2.5.21, 2.6.5 |

## How do I fix CVE-2025-64513?

Upgrade github.com/milvus-io/milvus to a fixed version for your release line: 0.10.3-0.20251107071934-6102f001a971, 2.4.24, 2.5.21 or 2.6.5.

## Is CVE-2025-64513 being exploited?

There is no known exploitation of CVE-2025-64513 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2025-64513 — Milvus Proxy Authentication Bypass Vulnerability   Batch scanner to verify unauthorized access and gather Milvus version, health, and database info.   For security research and defensive validation only. (github_poc): https://github.com/shinyseam/CVE-2025-64513
- Milvus 认证安全检测脚本：CVE-2025-64513 (sourceid后门) / CVE-2026-26190 (/expr弱token) / 内部端口53100 (github_poc): https://github.com/qianlijaingshan/milvus-auth-audit

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64513 and fix it if it is affected.

What it is: CVE-2025-64513 is a critical authentication bypass vulnerability in milvus-io milvus, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64513 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/milvus-io/milvus (Go): affected all versions; fixed in 0.10.3-0.20251107071934-6102f001a971
- github.com/milvus-io/milvus (Go): affected all versions; fixed in 0.10.3-0.20251107071934-6102f001a971
- github.com/milvus-io/milvus (Go): affected all versions; fixed in 0.10.3-0.20251107071934-6102f001a971
- github.com/milvus-io/milvus (Go): affected from 0.10.4; fixed in 2.4.24
- github.com/milvus-io/milvus (Go): affected from 0.10.4; fixed in 2.4.24
- github.com/milvus-io/milvus (Go): affected from 2.5.0; fixed in 2.5.21
- github.com/milvus-io/milvus (Go): affected from 2.5.0; fixed in 2.5.21
- github.com/milvus-io/milvus (Go): affected from 2.6.0; fixed in 2.6.5
- github.com/milvus-io/milvus (Go): affected from 2.6.0; fixed in 2.6.5
- milvus (Bitnami): affected all versions; fixed in 2.4.24, 2.5.21, 2.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64513/ (Markdown: https://insights.sbomify.com/CVE-2025-64513/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64513
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64513
- OSV: https://osv.dev/vulnerability/CVE-2025-64513

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64513/
Summaries are generated and may contain mistakes; the official description above is the record.
