CVE-2025-64516 GLPI incorrectly authorizes access to documents

High 7.5 Published Updated

Unauthorized users can access attached documents in GLPI, potentially exposing sensitive data if the public FAQ is enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-64516?

CVE-2025-64516 is a high-severity missing authorization vulnerability in Glpi-Project Glpi, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

GLPI is a free asset and IT management software package. Prior to 10.0.21 and 11.0.3, an unauthorized user can access GLPI documents attached to any item (ticket, asset, ...). If the public FAQ is enabled, this unauthorized access can be performed by an anonymous user. This vulnerability is fixed in 10.0.21 and 11.0.3.

Weakness: CWE-639, CWE-284

Which versions are affected by CVE-2025-64516?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2025-64516?

No fix has been published for CVE-2025-64516 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-64516 being exploited?

There is no known exploitation of CVE-2025-64516 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-487h-7mxm-7r46, UBUNTU-CVE-2025-64516.

Is CVE-2025-64516 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free