{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-64516 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-64516 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-64516 is a high-severity missing authorization vulnerability in Glpi-Project Glpi, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64516 and fix it if it is affected.\n\nWhat it is: CVE-2025-64516 is a high-severity missing authorization vulnerability in Glpi-Project Glpi, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-64516 in the wild and no public exploit code.\n\nAffected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64516/ (Markdown: https://insights.sbomify.com/CVE-2025-64516/index.md)","id":"CVE-2025-64516","markdown":"https://insights.sbomify.com/CVE-2025-64516/index.md","name":"CVE-2025-64516","record":{"aliases":["GHSA-487h-7mxm-7r46","UBUNTU-CVE-2025-64516"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"IT asset management","requires_auth":"none","summary":"Unauthorized users can access attached documents in GLPI, potentially exposing sensitive data if the public FAQ is enabled.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"glpi","vendor":"glpi-project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"GLPI is a free asset and IT management software package. Prior to 10.0.21 and 11.0.3, an unauthorized user can access GLPI documents attached to any item (ticket, asset, ...). If the public FAQ is enabled, this unauthorized access can be performed by an anonymous user. This vulnerability is fixed in 10.0.21 and 11.0.3.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2025-11-12","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-11-12T08:00:23Z","kind":"github_poc","ref":"https://github.com/ArdNoir/CVE-2025-64516-POC","stars":2,"title":"POC for Unauthorized access to documents. CVE-2025-64516"}],"tier":"poc_unverified"},"has_fix":false,"headline":"GLPI incorrectly authorizes access to documents","id":"CVE-2025-64516","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"glpi-project:glpi","products":["glpi-project:glpi"],"type":"missing_authorization","year":"2025"},"n_packages":0,"n_references":5,"next":{"headline":"sudo-rs doesn't record authenticating user properly in timestamp","id":"CVE-2025-64517"},"packages":[],"prev":{"headline":"Open Forms prefill data in read-only components can be tampered","id":"CVE-2025-64515"},"products":["glpi"],"published":"2026-01-15","related":[{"cvss_score":9.8,"headline":"Teclib GLPI Remote Code Execution","id":"CVE-2022-35914","kev_date_added":"2023-03-07","published":"2022-09-19"},{"cvss_score":10,"headline":"GLPI vulnerable to unallowed PHP script execution","id":"CVE-2023-42802","kev_date_added":null,"published":"2023-11-02"},{"cvss_score":10,"headline":"GLPI vulnerable to SQL injection and Stored XSS via inventory agent request","id":"CVE-2023-28849","kev_date_added":null,"published":"2023-04-05"},{"cvss_score":10,"headline":"SQL injection in GLPI","id":"CVE-2022-35947","kev_date_added":null,"published":"2022-09-14"},{"cvss_score":9.8,"headline":"SQL injection with _actor parameter in GLPI","id":"CVE-2022-31056","kev_date_added":null,"published":"2022-06-28"},{"cvss_score":9.8,"headline":"SQL injection on login page in GLPI","id":"CVE-2022-31061","kev_date_added":null,"published":"2022-06-28"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2021-44617","kev_date_added":null,"published":"2022-03-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-15","vendors":["glpi-project"]},"summary":"Unauthorized users can access attached documents in GLPI, potentially exposing sensitive data if the public FAQ is enabled.","url":"https://insights.sbomify.com/CVE-2025-64516/"}