# CVE-2025-64516: GLPI incorrectly authorizes access to documents

> Unauthorized users can access attached documents in GLPI, potentially exposing sensitive data if the public FAQ is enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Jan 2026
- **Updated:** 15 Jan 2026
- **Also known as:** GHSA-487h-7mxm-7r46, UBUNTU-CVE-2025-64516

## What is CVE-2025-64516?

CVE-2025-64516 is a high-severity missing authorization vulnerability in Glpi-Project Glpi, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GLPI is a free asset and IT management software package. Prior to 10.0.21 and 11.0.3, an unauthorized user can access GLPI documents attached to any item (ticket, asset, ...). If the public FAQ is enabled, this unauthorized access can be performed by an anonymous user. This vulnerability is fixed in 10.0.21 and 11.0.3.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-64516?

It affects 1 product.


Products: Glpi-Project Glpi.

## How do I fix CVE-2025-64516?

No fix has been published for CVE-2025-64516 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-64516 being exploited?

There is no known exploitation of CVE-2025-64516 in the wild and no public exploit code.

Public exploit code:

- POC for Unauthorized access to documents. CVE-2025-64516 (github_poc): https://github.com/ArdNoir/CVE-2025-64516-POC

## Other vulnerabilities in Glpi-Project Glpi

- [CVE-2022-35914](https://insights.sbomify.com/CVE-2022-35914/): Teclib GLPI Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2023-42802](https://insights.sbomify.com/CVE-2023-42802/): GLPI vulnerable to unallowed PHP script execution (critical 10.0)
- [CVE-2023-28849](https://insights.sbomify.com/CVE-2023-28849/): GLPI vulnerable to SQL injection and Stored XSS via inventory agent request (critical 10.0)
- [CVE-2022-35947](https://insights.sbomify.com/CVE-2022-35947/): SQL injection in GLPI (critical 10.0)
- [CVE-2022-31056](https://insights.sbomify.com/CVE-2022-31056/): SQL injection with _actor parameter in GLPI (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64516 and fix it if it is affected.

What it is: CVE-2025-64516 is a high-severity missing authorization vulnerability in Glpi-Project Glpi, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64516 in the wild and no public exploit code.

Affected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64516/ (Markdown: https://insights.sbomify.com/CVE-2025-64516/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64516
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64516
- OSV: https://osv.dev/vulnerability/CVE-2025-64516

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64516/
Summaries are generated and may contain mistakes; the official description above is the record.
