{"answers":{"affected":"2 open source packages ship an affected version, including sudo-rs.","exploited":"There is no known exploitation of CVE-2025-64517 in the wild and no public exploit code.","fix":"Upgrade sudo-rs to 0.2.10 or later.","what":"CVE-2025-64517 is a medium-severity authentication bypass vulnerability in trifectatechfoundation sudo-rs, published on 12 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64517 and fix it if it is affected.\n\nWhat it is: CVE-2025-64517 is a medium-severity authentication bypass vulnerability in trifectatechfoundation sudo-rs, published on 12 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-64517 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sudo-rs (crates.io): affected from 0.2.5; fixed in 0.2.10\n- sudo-rs (crates.io): affected from 0.2.5; fixed in 0.2.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64517/ (Markdown: https://insights.sbomify.com/CVE-2025-64517/index.md)","id":"CVE-2025-64517","markdown":"https://insights.sbomify.com/CVE-2025-64517/index.md","name":"CVE-2025-64517","record":{"aliases":["DEBIAN-CVE-2025-64517","GHSA-q428-6v73-fc4q","MINI-jqj9-rpx8-m9g9","UBUNTU-CVE-2025-64517"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["privilege_escalation","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"sudo-rs authentication tool","requires_auth":"high_privilege","summary":"Attackers can bypass authentication checks in sudo-rs when targetpw is enabled, allowing unauthorized privilege escalation to other accounts.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"sudo-rs is a memory safe implementation of sudo and su written in Rust. With `Defaults targetpw` (or `Defaults rootpw`) enabled,  the password of the target account (or root account) instead of the invoking user is used for authentication. sudo-rs starting in version 0.2.5 and prior to version 0.2.10 incorrectly recorded the invoking user’s UID instead of the authenticated-as user's UID in the authentication timestamp. Any later `sudo` invocation on the same terminal while the timestamp was still valid would use that timestamp, potentially bypassing new authentication even if the policy would have required it. A highly-privileged user (able to run commands as other users, or as root, through sudo) who knows one password of an account they are allowed to run commands as, would be able to run commands as any other account the policy permits them to run commands for, even if they don't know the password for those accounts. A common instance of this would be that a user can still use their own password to run commands as root (the default behaviour of `sudo`), effectively negating the intended behaviour of the `targetpw` or `rootpw` options. Version 0.2.10 contains a patch for the issue. Versions prior to 0.2.5 are not affected, since they do not offer `Defaults targetpw` or `Defaults rootpw`.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"sudo-rs doesn't record authenticating user properly in timestamp","id":"CVE-2025-64517","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"CycloneDX Core (Java): BOM validation is vulnerable to XML External Entity injection","id":"CVE-2025-64518"},"packages":[{"ecosystem":"crates.io","fixed":["0.2.10"],"introduced":["0.2.5"],"last_affected":[],"package":"sudo-rs","purl":null,"source":"GHSA-q428-6v73-fc4q"},{"ecosystem":"crates.io","fixed":["0.2.10"],"introduced":["0.2.5"],"last_affected":[],"package":"sudo-rs","purl":"pkg:cargo/sudo-rs","source":"GHSA-q428-6v73-fc4q"}],"prev":{"headline":"GLPI incorrectly authorizes access to documents","id":"CVE-2025-64516"},"products":["sudo-rs"],"published":"2025-11-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-12","vendors":["trifectatechfoundation"]},"summary":"Attackers can bypass authentication checks in sudo-rs when targetpw is enabled, allowing unauthorized privilege escalation to other accounts.","url":"https://insights.sbomify.com/CVE-2025-64517/"}