# CVE-2025-64517: sudo-rs doesn't record authenticating user properly in timestamp

> Attackers can bypass authentication checks in sudo-rs when targetpw is enabled, allowing unauthorized privilege escalation to other accounts.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Nov 2025
- **Updated:** 12 Feb 2026
- **Also known as:** DEBIAN-CVE-2025-64517, GHSA-q428-6v73-fc4q, MINI-jqj9-rpx8-m9g9, UBUNTU-CVE-2025-64517

## What is CVE-2025-64517?

CVE-2025-64517 is a medium-severity authentication bypass vulnerability in trifectatechfoundation sudo-rs, published on 12 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

sudo-rs is a memory safe implementation of sudo and su written in Rust. With `Defaults targetpw` (or `Defaults rootpw`) enabled,  the password of the target account (or root account) instead of the invoking user is used for authentication. sudo-rs starting in version 0.2.5 and prior to version 0.2.10 incorrectly recorded the invoking user’s UID instead of the authenticated-as user's UID in the authentication timestamp. Any later `sudo` invocation on the same terminal while the timestamp was still valid would use that timestamp, potentially bypassing new authentication even if the policy would have required it. A highly-privileged user (able to run commands as other users, or as root, through sudo) who knows one password of an account they are allowed to run commands as, would be able to run commands as any other account the policy permits them to run commands for, even if they don't know the password for those accounts. A common instance of this would be that a user can still use their own password to run commands as root (the default behaviour of `sudo`), effectively negating the intended behaviour of the `targetpw` or `rootpw` options. Version 0.2.10 contains a patch for the issue. Versions prior to 0.2.5 are not affected, since they do not offer `Defaults targetpw` or `Defaults rootpw`.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-64517?

2 open source packages ship an affected version, including sudo-rs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sudo-rs` | crates.io | From 0.2.5 | 0.2.10 |
| `sudo-rs` | crates.io | From 0.2.5 | 0.2.10 |

## How do I fix CVE-2025-64517?

Upgrade sudo-rs to 0.2.10 or later.

## Is CVE-2025-64517 being exploited?

There is no known exploitation of CVE-2025-64517 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64517 and fix it if it is affected.

What it is: CVE-2025-64517 is a medium-severity authentication bypass vulnerability in trifectatechfoundation sudo-rs, published on 12 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64517 in the wild and no public exploit code.

Affected packages and fixed versions:
- sudo-rs (crates.io): affected from 0.2.5; fixed in 0.2.10
- sudo-rs (crates.io): affected from 0.2.5; fixed in 0.2.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64517/ (Markdown: https://insights.sbomify.com/CVE-2025-64517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64517
- OSV: https://osv.dev/vulnerability/CVE-2025-64517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64517/
Summaries are generated and may contain mistakes; the official description above is the record.
