# CVE-2025-64518: CycloneDX Core (Java): BOM validation is vulnerable to XML External Entity injection

> An attacker can exploit XML External Entity injection in CycloneDX Core Java validation to read sensitive files or cause denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2025
- **Updated:** 12 Nov 2025
- **Also known as:** GHSA-6fhj-vr9j-g45r

## What is CVE-2025-64518?

CVE-2025-64518 is a high-severity vulnerability in cyclonedx-core-java, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The CycloneDX core module provides a model representation of the SBOM along with utilities to assist in creating, validating, and parsing SBOMs. Starting in version 2.1.0 and prior to version 11.0.1, the XML `Validator` used by cyclonedx-core-java was not configured securely, making the library vulnerable to XML External Entity (XXE) injection. The fix for GHSA-683x-4444-jxh8 / CVE-2024-38374 was incomplete in that it only fixed parsing of XML BOMs, but not validation. The vulnerability has been fixed in cyclonedx-core-java version 11.0.1. As a workaround, applications can reject XML documents before handing them to cyclonedx-core-java for validation. This may be an option if incoming CycloneDX BOMs are known to be in JSON format.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2025-64518?

2 open source packages ship an affected version, including org.cyclonedx:cyclonedx-core-java.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cyclonedx:cyclonedx-core-java` | Maven | From 2.1.0 | 11.0.1 |
| `org.cyclonedx:cyclonedx-core-java` | Maven | From 2.1.0 | 11.0.1 |

## How do I fix CVE-2025-64518?

Upgrade org.cyclonedx:cyclonedx-core-java to 11.0.1 or later.

## Is CVE-2025-64518 being exploited?

There is no known exploitation of CVE-2025-64518 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64518 and fix it if it is affected.

What it is: CVE-2025-64518 is a high-severity vulnerability in cyclonedx-core-java, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64518 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cyclonedx:cyclonedx-core-java (Maven): affected from 2.1.0; fixed in 11.0.1
- org.cyclonedx:cyclonedx-core-java (Maven): affected from 2.1.0; fixed in 11.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64518/ (Markdown: https://insights.sbomify.com/CVE-2025-64518/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64518
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64518
- OSV: https://osv.dev/vulnerability/CVE-2025-64518

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64518/
Summaries are generated and may contain mistakes; the official description above is the record.
