CVE-2025-64520 GLPI vulnerable to unauthorized access to restricted Knowledge Base items through the API

Medium 6.5 Published Updated

An unauthorized user with API access can read all restricted Knowledge Base entries in GLPI, exposing sensitive internal documentation.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-64520?

CVE-2025-64520 is a medium-severity missing authorization vulnerability in Glpi-Project Glpi, published on 16 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GLPI is a free asset and IT management software package. Starting in version 9.1.0 and prior to version 10.0.21, an unauthorized user with an API access can read all knowledge base entries. Users should upgrade to 10.0.21 to receive a patch.

Weakness: CWE-862

Which versions are affected by CVE-2025-64520?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2025-64520?

No fix has been published for CVE-2025-64520 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-64520 being exploited?

There is no known exploitation of CVE-2025-64520 in the wild and no public exploit code.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-62p9-prpq-j62q, UBUNTU-CVE-2025-64520.

Is CVE-2025-64520 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free