# CVE-2025-64526: Strapi has a rate limit bypass on users-permissions plugin via attacker-controlled email keying

> An attacker can bypass rate limiting on authentication routes by manipulating the email field, enabling brute-force attacks against credentials.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 16 May 2026
- **Also known as:** GHSA-7mqx-wwh4-f9fw

## What is CVE-2025-64526?

CVE-2025-64526 is a medium-severity vulnerability in @strapi/plugin-users-permissions, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Strapi is an open source headless content management system. In Strapi versions prior to 5.45.0, the rate-limit middleware in the users-permissions plugin derived its rate-limit key in part from `ctx.request.body.email`, including on routes whose body schema does not contain an `email` field (`/auth/local`, `/auth/reset-password`, `/auth/change-password`). An unauthenticated attacker could include an arbitrary `email` value in the request body to obtain a fresh rate-limit key per request, effectively bypassing per-IP throttling on those routes and enabling high-volume credential brute-force, password-reset code brute-force, and credential-stuffing attempts. The rate-limit key was constructed as `${userIdentifier}:${requestPath}:${ctx.request.ip}`, where `userIdentifier = ctx.request.body.email`. On routes that legitimately use email as their identifier (e.g. `/auth/forgot-password`, `/auth/local/register`), this scoping is correct. On routes that use a different identifier (`identifier` for login, `code` for password reset, `currentPassword` for password change), the email field was not part of the route contract, but the middleware still incorporated it into the key, allowing a caller to rotate the value and obtain a unique key on every request. The patch in version 5.45.0 maintains an allow-list of routes that legitimately key on the email field and excludes that key component on every other route the middleware is mounted on. OAuth callback paths (`/connect/*`) are treated identifier-less. On routes outside the allow-list, the middleware now falls back to a fixed identifier-less key, ensuring per-IP throttling remains effective even when the request body is attacker-controlled.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2025-64526?

2 open source packages ship an affected version, including @strapi/plugin-users-permissions. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/plugin-users-permissions` | npm | All versions | 5.45.0 |
| `@strapi/plugin-users-permissions` | npm | All versions | 5.45.0 |

Products: Strapi Strapi.

## How do I fix CVE-2025-64526?

Upgrade @strapi/plugin-users-permissions to 5.45.0 or later.

## Is CVE-2025-64526 being exploited?

There is no known exploitation of CVE-2025-64526 in the wild and no public exploit code.

## Other vulnerabilities in @strapi/plugin-users-permissions

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64526 and fix it if it is affected.

What it is: CVE-2025-64526 is a medium-severity vulnerability in @strapi/plugin-users-permissions, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64526 in the wild and no public exploit code.

Affected packages and fixed versions:
- @strapi/plugin-users-permissions (npm): affected all versions; fixed in 5.45.0
- @strapi/plugin-users-permissions (npm): affected all versions; fixed in 5.45.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64526/ (Markdown: https://insights.sbomify.com/CVE-2025-64526/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64526
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64526
- OSV: https://osv.dev/vulnerability/CVE-2025-64526

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64526/
Summaries are generated and may contain mistakes; the official description above is the record.
