CVE-2025-64527 Envoy crashes when JWT authentication is configured with the remote JWKS fetching
Attackers can crash Envoy proxy by sending multiple JWT tokens when remote JWKS fetching fails, causing a null dereference in the fetcher logic.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64527?
CVE-2025-64527 is a medium-severity vulnerability in Envoyproxy Envoy, published on 3 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Envoy is a high-performance edge/middle/service proxy. In 1.33.12, 1.34.10, 1.35.6, 1.36.2, and earlier, Envoy crashes when JWT authentication is configured with the remote JWKS fetching, allow_missing_or_failed is enabled, multiple JWT tokens are present in the request headers and the JWKS fetch fails. This is caused by a re-entry bug in the JwksFetcherImpl. When the first token's JWKS fetch fails, onJwksError() callback triggers processing of the second token, which calls fetch() again on the same fetcher object. The original callback's reset() then clears the second fetch's state (receiver_ and request_) which causes a crash when the async HTTP response arrives.
Weakness: CWE-476
Which versions are affected by CVE-2025-64527?
9 open source packages ship an affected version, including github.com/envoyproxy/envoy and envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/envoyproxy/envoy Go | All versions | 1.33.13 |
github.com/envoyproxy/envoy Go | All versions | 1.33.13 |
github.com/envoyproxy/envoy Go | From 1.34.0 | 1.34.11 |
github.com/envoyproxy/envoy Go | From 1.34.0 | 1.34.11 |
github.com/envoyproxy/envoy Go | From 1.35.0 | 1.35.7 |
github.com/envoyproxy/envoy Go | From 1.35.0 | 1.35.7 |
3 more packages
github.com/envoyproxy/envoy Go | From 1.36.0 | 1.36.3 |
github.com/envoyproxy/envoy Go | From 1.36.0 | 1.36.3 |
envoy Bitnami | All versions | 1.33.13, 1.34.11, 1.35.7, 1.36.3 |
Products include Envoyproxy Envoy.
How do I fix CVE-2025-64527?
Upgrade github.com/envoyproxy/envoy to a fixed version for your release line: 1.33.13, 1.34.11, 1.35.7 or 1.36.3.
Is CVE-2025-64527 being exploited?
There is no known exploitation of CVE-2025-64527 in the wild and no public exploit code.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2025-64527, GHSA-mp85-7mrq-r866.