# CVE-2025-64527: Envoy crashes when JWT authentication is configured with the remote JWKS fetching

> Attackers can crash Envoy proxy by sending multiple JWT tokens when remote JWKS fetching fails, causing a null dereference in the fetcher logic.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Dec 2025
- **Updated:** 3 Dec 2025
- **Also known as:** BIT-envoy-2025-64527, GHSA-mp85-7mrq-r866

## What is CVE-2025-64527?

CVE-2025-64527 is a medium-severity vulnerability in Envoyproxy Envoy, published on 3 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Envoy is a high-performance edge/middle/service proxy. In 1.33.12, 1.34.10, 1.35.6, 1.36.2, and earlier, Envoy crashes when JWT authentication is configured with the remote JWKS fetching, allow_missing_or_failed is enabled, multiple JWT tokens are present in the request headers and the JWKS fetch fails. This is caused by a re-entry bug in the JwksFetcherImpl. When the first token's JWKS fetch fails, onJwksError() callback triggers processing of the second token, which calls fetch() again on the same fetcher object. The original callback's reset() then clears the second fetch's state (receiver_ and request_) which causes a crash when the async HTTP response arrives.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2025-64527?

9 open source packages ship an affected version, including github.com/envoyproxy/envoy and envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/envoyproxy/envoy` | Go | All versions | 1.33.13 |
| `github.com/envoyproxy/envoy` | Go | All versions | 1.33.13 |
| `github.com/envoyproxy/envoy` | Go | From 1.34.0 | 1.34.11 |
| `github.com/envoyproxy/envoy` | Go | From 1.34.0 | 1.34.11 |
| `github.com/envoyproxy/envoy` | Go | From 1.35.0 | 1.35.7 |
| `github.com/envoyproxy/envoy` | Go | From 1.35.0 | 1.35.7 |
| `github.com/envoyproxy/envoy` | Go | From 1.36.0 | 1.36.3 |
| `github.com/envoyproxy/envoy` | Go | From 1.36.0 | 1.36.3 |
| `envoy` | Bitnami | All versions | 1.33.13, 1.34.11, 1.35.7, 1.36.3 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2025-64527?

Upgrade github.com/envoyproxy/envoy to a fixed version for your release line: 1.33.13, 1.34.11, 1.35.7 or 1.36.3.

## Is CVE-2025-64527 being exploited?

There is no known exploitation of CVE-2025-64527 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64527 and fix it if it is affected.

What it is: CVE-2025-64527 is a medium-severity vulnerability in Envoyproxy Envoy, published on 3 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64527 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/envoyproxy/envoy (Go): affected all versions; fixed in 1.33.13
- github.com/envoyproxy/envoy (Go): affected all versions; fixed in 1.33.13
- github.com/envoyproxy/envoy (Go): affected from 1.34.0; fixed in 1.34.11
- github.com/envoyproxy/envoy (Go): affected from 1.34.0; fixed in 1.34.11
- github.com/envoyproxy/envoy (Go): affected from 1.35.0; fixed in 1.35.7
- github.com/envoyproxy/envoy (Go): affected from 1.35.0; fixed in 1.35.7
- github.com/envoyproxy/envoy (Go): affected from 1.36.0; fixed in 1.36.3
- github.com/envoyproxy/envoy (Go): affected from 1.36.0; fixed in 1.36.3
- envoy (Bitnami): affected all versions; fixed in 1.33.13, 1.34.11, 1.35.7, 1.36.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64527/ (Markdown: https://insights.sbomify.com/CVE-2025-64527/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64527
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64527
- OSV: https://osv.dev/vulnerability/CVE-2025-64527

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64527/
Summaries are generated and may contain mistakes; the official description above is the record.
