# CVE-2025-64528: Users are able to find users by name even when `enable_names` is off

> Attackers can discover user full names via UI or API despite the enable_names setting being disabled, exposing private user data.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Dec 2025
- **Updated:** 30 Dec 2025
- **Also known as:** BIT-discourse-2025-64528, GHSA-c59w-jwx7-34v4

## What is CVE-2025-64528?

CVE-2025-64528 is a medium-severity vulnerability in Discourse Discourse, published on 30 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open source discussion platform. Prior to versions 3.5.3, 2025.11.1, and 2025.12.0, an attacker who knows part of a username can find the user and their full name via UI or API, even when `enable_names` is disabled. Versions 3.5.3, 2025.11.1, and 2025.12.0 contain a fix.

Weakness: CWE-202 (Exposure of Sensitive Information Through Data Queries)

## Which versions are affected by CVE-2025-64528?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.5.3, 2025.11.1 |

Products: Discourse Discourse.

## How do I fix CVE-2025-64528?

Upgrade discourse to a fixed version for your release line: 3.5.3 or 2025.11.1.

## Is CVE-2025-64528 being exploited?

There is no known exploitation of CVE-2025-64528 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64528 and fix it if it is affected.

What it is: CVE-2025-64528 is a medium-severity vulnerability in Discourse Discourse, published on 30 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64528 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.5.3, 2025.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64528/ (Markdown: https://insights.sbomify.com/CVE-2025-64528/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64528
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64528
- OSV: https://osv.dev/vulnerability/CVE-2025-64528

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64528/
Summaries are generated and may contain mistakes; the official description above is the record.
