# CVE-2025-64529: SpiceDB's WriteRelationships fails silently if payload is too big

> Attackers can bypass authorization checks in SpiceDB by triggering silent failures in relationship writes under specific high-volume configurations.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2025
- **Updated:** 12 Nov 2025
- **Also known as:** GHSA-pm3x-jrhh-qcr7, GO-2025-4120

## What is CVE-2025-64529?

CVE-2025-64529 is a low-severity vulnerability in authzed spicedb, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SpiceDB is an open source database system for creating and managing security-critical application permissions. In versions prior to 1.45.2, users who use the exclusion operator somewhere in their authorization schema; have configured their SpiceDB server such that `--write-relationships-max-updates-per-call` is bigger than 6500; and issue calls to WriteRelationships with a large enough number of updates that cause the payload to be bigger than what their datastore allows; will receive a successful response from their `WriteRelationships` call, when in reality that call failed, and receive incorrect permission check results, if those relationships had to be read to resolve the relation involving the exclusion. Version 1.45.2 contains a patch for the issue. As a workaround, set `--write-relationships-max-updates-per-call` to `1000`.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-64529?

3 open source packages ship an affected version, including github.com/authzed/spicedb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/authzed/spicedb` | Go | All versions | 1.45.2 |
| `github.com/authzed/spicedb` | Go | All versions | 1.45.2 |
| `github.com/authzed/spicedb` | Go | All versions | 1.45.2 |

Products: Authzed Spicedb.

## How do I fix CVE-2025-64529?

Upgrade github.com/authzed/spicedb to 1.45.2 or later.

## Is CVE-2025-64529 being exploited?

There is no known exploitation of CVE-2025-64529 in the wild and no public exploit code.

## Other vulnerabilities in authzed spicedb

- [CVE-2023-29193](https://insights.sbomify.com/CVE-2023-29193/): SpiceDB binding metrics port to untrusted networks and can leak command-line flags (high 8.7)
- [CVE-2022-21646](https://insights.sbomify.com/CVE-2022-21646/): Lookup operations do not take into account wildcards in SpiceDB (high 8.1)
- [CVE-2024-27101](https://insights.sbomify.com/CVE-2024-27101/): Integer overflow in chunking helper causes dispatching to miss elements or panic (high 7.3)
- [CVE-2026-40091](https://insights.sbomify.com/CVE-2026-40091/): SpiceDB: SPICEDB_DATASTORE_CONN_URI is leaked on startup logs (medium 6.0)
- [CVE-2023-46255](https://insights.sbomify.com/CVE-2023-46255/): `SPICEDB_DATASTORE_CONN_URI` is leaked when URI cannot be parsed (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64529 and fix it if it is affected.

What it is: CVE-2025-64529 is a low-severity vulnerability in authzed spicedb, published on 10 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64529 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.45.2
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.45.2
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.45.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64529/ (Markdown: https://insights.sbomify.com/CVE-2025-64529/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64529
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64529
- OSV: https://osv.dev/vulnerability/CVE-2025-64529

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64529/
Summaries are generated and may contain mistakes; the official description above is the record.
