CVE-2025-64530 @apollo/composition has Improper Enforcement of Access Control on Interface Types and Fields
Attackers can bypass access controls on interface fields by querying implementing types, exposing restricted data in Apollo Router.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64530?
CVE-2025-64530 is a high-severity missing authorization vulnerability in apollographql federation, published on 13 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apollo Federation is an architecture for declaratively composing APIs into a unified graph. A vulnerability in versions of Apollo Federation's composition logic prior to 2.9.5, 2.10.4, 2.11.5, and 2.12.1 allowed some queries to Apollo Router to improperly bypass access controls on types/fields. Apollo Federation incorrectly allowed user-defined access control directives on interface types/fields, which could be bypassed by instead querying the implementing object types/fields in Apollo Router via inline fragments, for example. A fix to versions 2.9.5, 2.10.4, 2.11.5, and 2.12.1 of composition logic in Federation now disallows interfaces types and fields to contain user-defined access control directives. Some workarounds are available. Users of Apollo Rover with an unpatched composition version or are using the Apollo Studio build pipeline with Federation version 2.8 or below should manually copy the access control requirements on interface types/fields to each implementing object type/field where appropriate. Do not remove those access control requirements from the interface types/fields, as unpatched Apollo Composition will not automatically generate them in the supergraph schema. Customers not using Apollo Router access control features (`@authenticated`, `@requiresScopes`, or `@policy` directives) or not specifying access control requirements on interface types/fields are not affected and do not need to take action.
Weakness: CWE-288
Which versions are affected by CVE-2025-64530?
8 open source packages ship an affected version, including @apollo/composition.
| Package | Affected | Fixed in |
|---|---|---|
@apollo/composition npm | All versions | 2.9.5 |
@apollo/composition npm | All versions | 2.9.5 |
@apollo/composition npm | From 2.10.0-alpha.3 | 2.10.4 |
@apollo/composition npm | From 2.10.0-alpha.3 | 2.10.4 |
@apollo/composition npm | From 2.11.0-preview.1 | 2.11.5 |
@apollo/composition npm | From 2.11.0-preview.1 | 2.11.5 |
2 more packages
@apollo/composition npm | From 2.12.0-preview.1 | 2.12.1 |
@apollo/composition npm | From 2.12.0-preview.1 | 2.12.1 |
How do I fix CVE-2025-64530?
Upgrade @apollo/composition to a fixed version for your release line: 2.9.5, 2.10.4, 2.11.5 or 2.12.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-64530 being exploited?
There is no known exploitation of CVE-2025-64530 in the wild and no public exploit code.
Sources
Also known as GHSA-mx7m-j9xf-62hw, ROOT-APP-NPM-CVE-2025-64530.