CVE-2025-6454 Server-Side Request Forgery (SSRF) in GitLab

High 8.5 Published Updated

Authenticated users can exploit SSRF in GitLab to make unintended internal requests via proxy environments, potentially accessing internal resources.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-6454?

CVE-2025-6454 is a high-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 12 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 16.11 before 18.1.6, 18.2 before 18.2.6, and 18.3 before 18.3.2 that could have allowed authenticated users to make unintended internal requests through proxy environments by injecting crafted sequences.

Weakness: CWE-918

Which versions are affected by CVE-2025-6454?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.11.018.1.6, 18.2.6, 18.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-6454?

Upgrade gitlab to a fixed version for your release line: 18.1.6, 18.2.6 or 18.3.2.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2025-6454 being exploited?

There is no known exploitation of CVE-2025-6454 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-6454, GHSA-j42x-rxgc-89xm.

Is CVE-2025-6454 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free