# CVE-2025-6454: Server-Side Request Forgery (SSRF) in GitLab

> Authenticated users can exploit SSRF in GitLab to make unintended internal requests via proxy environments, potentially accessing internal resources.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Sep 2025
- **Updated:** 12 Sep 2025
- **Also known as:** BIT-gitlab-2025-6454, GHSA-j42x-rxgc-89xm

## What is CVE-2025-6454?

CVE-2025-6454 is a high-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 12 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 16.11 before 18.1.6, 18.2 before 18.2.6, and 18.3 before 18.3.2 that could have allowed authenticated users to make unintended internal requests through proxy environments by injecting crafted sequences.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-6454?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 16.11.0 | 18.1.6, 18.2.6, 18.3.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2025-6454?

Upgrade gitlab to a fixed version for your release line: 18.1.6, 18.2.6 or 18.3.2.

## Is CVE-2025-6454 being exploited?

There is no known exploitation of CVE-2025-6454 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6454 and fix it if it is affected.

What it is: CVE-2025-6454 is a high-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 12 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-6454 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 16.11.0; fixed in 18.1.6, 18.2.6, 18.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6454/ (Markdown: https://insights.sbomify.com/CVE-2025-6454/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6454
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6454
- OSV: https://osv.dev/vulnerability/CVE-2025-6454

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6454/
Summaries are generated and may contain mistakes; the official description above is the record.
