CVE-2025-64641 Mattermost Jira plugin crafted action leaks Jira issue details
A malicious user can exfiltrate Jira ticket details by crafting post actions that bypass plugin verification checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-64641?
CVE-2025-64641 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 24 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Mattermost versions 11.1.x <= 11.1.0, 11.0.x <= 11.0.5, 10.12.x <= 10.12.3, 10.11.x <= 10.11.7 fail to verify that post actions invoking /share-issue-publicly were created by the Jira plugin which allowed a malicious Mattermost user to exfiltrate Jira tickets when victim users interacted with affected posts
Weakness: CWE-863
Which versions are affected by CVE-2025-64641?
14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.8 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.8 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.8+incompatible, 10.12.4+incompatible, 11.0.6+incompatible, 11.1.1+incompatible |
github.com/mattermost/mattermost-server Go | From 10.12.0 | 10.12.4 |
github.com/mattermost/mattermost-server Go | From 10.12.0 | 10.12.4 |
github.com/mattermost/mattermost-server Go | From 11.0.0 | 11.0.6 |
8 more packages
github.com/mattermost/mattermost-server Go | From 11.0.0 | 11.0.6 |
github.com/mattermost/mattermost-server Go | From 11.1.0 | 11.1.1 |
github.com/mattermost/mattermost-server Go | From 11.1.0 | 11.1.1 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20251121122154-b57c297c6d7 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20251121122154-b57c297c6d7 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-64641?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.8, 10.11.8+incompatible, 10.12.4+incompatible or 11.0.6+incompatible.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-64641 being exploited?
There is no known exploitation of CVE-2025-64641 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-vww6-79rv-3j4x, GO-2025-4260.