# CVE-2025-64641: Mattermost Jira plugin crafted action leaks Jira issue details

> A malicious user can exfiltrate Jira ticket details by crafting post actions that bypass plugin verification checks.

- **Severity:** Medium 4.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Dec 2025
- **Updated:** 24 Dec 2025
- **Also known as:** GHSA-vww6-79rv-3j4x, GO-2025-4260

## What is CVE-2025-64641?

CVE-2025-64641 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 24 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Mattermost versions 11.1.x <= 11.1.0, 11.0.x <= 11.0.5, 10.12.x <= 10.12.3, 10.11.x <= 10.11.7 fail to verify that post actions invoking /share-issue-publicly were created by the Jira plugin which allowed a malicious Mattermost user to exfiltrate Jira tickets when victim users interacted with affected posts

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-64641?

14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.8 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.8 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0+incompatible | 10.11.8+incompatible, 10.12.4+incompatible, 11.0.6+incompatible, 11.1.1+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 10.12.0 | 10.12.4 |
| `github.com/mattermost/mattermost-server` | Go | From 10.12.0 | 10.12.4 |
| `github.com/mattermost/mattermost-server` | Go | From 11.0.0 | 11.0.6 |
| `github.com/mattermost/mattermost-server` | Go | From 11.0.0 | 11.0.6 |
| `github.com/mattermost/mattermost-server` | Go | From 11.1.0 | 11.1.1 |
| `github.com/mattermost/mattermost-server` | Go | From 11.1.0 | 11.1.1 |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251121122154-b57c297c6d7 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251121122154-b57c297c6d7 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-64641?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.8, 10.11.8+incompatible, 10.12.4+incompatible or 11.0.6+incompatible.

## Is CVE-2025-64641 being exploited?

There is no known exploitation of CVE-2025-64641 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64641 and fix it if it is affected.

What it is: CVE-2025-64641 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 24 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-64641 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.8
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.8
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0+incompatible; fixed in 10.11.8+incompatible, 10.12.4+incompatible, 11.0.6+incompatible, 11.1.1+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 10.12.0; fixed in 10.12.4
- github.com/mattermost/mattermost-server (Go): affected from 10.12.0; fixed in 10.12.4
- github.com/mattermost/mattermost-server (Go): affected from 11.0.0; fixed in 11.0.6
- github.com/mattermost/mattermost-server (Go): affected from 11.0.0; fixed in 11.0.6
- github.com/mattermost/mattermost-server (Go): affected from 11.1.0; fixed in 11.1.1
- github.com/mattermost/mattermost-server (Go): affected from 11.1.0; fixed in 11.1.1
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64641/ (Markdown: https://insights.sbomify.com/CVE-2025-64641/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64641
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64641
- OSV: https://osv.dev/vulnerability/CVE-2025-64641

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64641/
Summaries are generated and may contain mistakes; the official description above is the record.
