CVE-2025-6465 Path traversal in image upload with preview overwrite
Attackers with upload permissions can overwrite file thumbnails via path traversal in Mattermost file streaming APIs.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6465?
CVE-2025-6465 is a medium-severity path traversal vulnerability in Mattermost Mattermost Server, published on 21 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 10.10.x <= 10.10.0, 10.9.x <= 10.9.3 fail to sanitize file names which allows users with file upload permission to overwrite file attachment thumbnails via path traversal in file streaming APIs.
Weakness: CWE-22
Which versions are affected by CVE-2025-6465?
14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.10.0 | 10.10.1 |
github.com/mattermost/mattermost-server Go | From 10.10.0 | 10.10.1 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 10.5.0+incompatible | 10.5.9+incompatible, 10.8.4+incompatible, 10.9.4+incompatible, 10.10.1+incompatible |
github.com/mattermost/mattermost-server Go | From 10.8.0 | 10.8.4 |
8 more packages
github.com/mattermost/mattermost-server Go | From 10.8.0 | 10.8.4 |
github.com/mattermost/mattermost-server Go | From 10.9.0 | 10.9.4 |
github.com/mattermost/mattermost-server Go | From 10.9.0 | 10.9.4 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250708173752-d6b35c41f0ae5 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250708173752-d6b35c41f0ae5 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-6465?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.10.1, 10.5.9, 10.5.9+incompatible or 10.8.4+incompatible.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-6465 being exploited?
There is no known exploitation of CVE-2025-6465 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-pj6f-rc94-gw53, GO-2025-3910.