# CVE-2025-6465: Path traversal in image upload with preview overwrite

> Attackers with upload permissions can overwrite file thumbnails via path traversal in Mattermost file streaming APIs.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2025
- **Updated:** 21 Aug 2025
- **Also known as:** GHSA-pj6f-rc94-gw53, GO-2025-3910

## What is CVE-2025-6465?

CVE-2025-6465 is a medium-severity path traversal vulnerability in Mattermost Mattermost Server, published on 21 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 10.10.x <= 10.10.0, 10.9.x <= 10.9.3 fail to sanitize file names which allows users with file upload permission to overwrite file attachment thumbnails via path traversal in file streaming APIs.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-6465?

14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.10.0 | 10.10.1 |
| `github.com/mattermost/mattermost-server` | Go | From 10.10.0 | 10.10.1 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.9 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.9 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0+incompatible | 10.5.9+incompatible, 10.8.4+incompatible, 10.9.4+incompatible, 10.10.1+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 10.8.0 | 10.8.4 |
| `github.com/mattermost/mattermost-server` | Go | From 10.8.0 | 10.8.4 |
| `github.com/mattermost/mattermost-server` | Go | From 10.9.0 | 10.9.4 |
| `github.com/mattermost/mattermost-server` | Go | From 10.9.0 | 10.9.4 |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250708173752-d6b35c41f0ae5 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250708173752-d6b35c41f0ae5 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-6465?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.10.1, 10.5.9, 10.5.9+incompatible or 10.8.4+incompatible.

## Is CVE-2025-6465 being exploited?

There is no known exploitation of CVE-2025-6465 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6465 and fix it if it is affected.

What it is: CVE-2025-6465 is a medium-severity path traversal vulnerability in Mattermost Mattermost Server, published on 21 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-6465 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.10.0; fixed in 10.10.1
- github.com/mattermost/mattermost-server (Go): affected from 10.10.0; fixed in 10.10.1
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.9
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.9
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0+incompatible; fixed in 10.5.9+incompatible, 10.8.4+incompatible, 10.9.4+incompatible, 10.10.1+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 10.8.0; fixed in 10.8.4
- github.com/mattermost/mattermost-server (Go): affected from 10.8.0; fixed in 10.8.4
- github.com/mattermost/mattermost-server (Go): affected from 10.9.0; fixed in 10.9.4
- github.com/mattermost/mattermost-server (Go): affected from 10.9.0; fixed in 10.9.4
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6465/ (Markdown: https://insights.sbomify.com/CVE-2025-6465/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6465
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6465
- OSV: https://osv.dev/vulnerability/CVE-2025-6465

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6465/
Summaries are generated and may contain mistakes; the official description above is the record.
