# CVE-2025-64702: quic-go HTTP/3 QPACK Header Expansion DoS

> Attackers can cause memory exhaustion and denial of service in quic-go applications by sending crafted QPACK-encoded HTTP/3 headers.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2025
- **Updated:** 12 Dec 2025
- **Also known as:** CLEANSTART-2026-DX97509, CLEANSTART-2026-EJ15157, CLEANSTART-2026-QC97945, DEBIAN-CVE-2025-64702, GHSA-g754-hx8w-x2g6, GO-2025-4233, MINI-2gjr-97pm-8hgq, MINI-2hmv-pmjh-99gw, MINI-37cf-hj53-v5mp, MINI-46wr-hmc6-43f5, MINI-4g43-4j8v-9qmg, MINI-4wxp-6whp-p79x, MINI-5v5c-mg67-wxpg, MINI-6765-26m2-x87q, MINI-6wm7-8wf8-489h, MINI-9w6c-gv6m-prr8, MINI-9x4p-cmvp-jrmr, MINI-g2m6-rf5f-wmw4, MINI-g3g4-64fr-gc9p, MINI-gp9c-vvwm-mv93, MINI-jc5c-hhhr-phjc, MINI-m2rf-x38w-52m7, MINI-m3x4-6vh8-c6x6, MINI-qwgq-58cx-9j7c, MINI-rxg5-xj7j-fc78, MINI-vw2p-93mg-29pc, UBUNTU-CVE-2025-64702, openSUSE-SU-2026:10035-1

## What is CVE-2025-64702?

CVE-2025-64702 is a medium-severity denial of service vulnerability in quic-go, published on 11 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

quic-go is an implementation of the QUIC protocol in Go. Versions 0.56.0 and below are vulnerable to excessive memory allocation through quic-go's HTTP/3 client and server implementations by sending a QPACK-encoded HEADERS frame that decodes into a large header field section (many unique header names and/or large values). The implementation builds an http.Header (used on the http.Request and http.Response, respectively), while only enforcing limits on the size of the (QPACK-compressed) HEADERS frame, but not on the decoded header, leading to memory exhaustion. This issue is fixed in version 0.57.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-64702?

3 open source packages ship an affected version, including github.com/quic-go/quic-go. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/quic-go/quic-go` | Go | All versions | 0.57.0 |
| `github.com/quic-go/quic-go` | Go | All versions | 0.57.0 |
| `github.com/quic-go/quic-go` | Go | All versions | 0.57.0 |
| `teleport` | openSUSE:Tumbleweed | All versions | 17.7.13-1.1 |

Products: Quic-Go Project Quic-Go.

## How do I fix CVE-2025-64702?

Upgrade github.com/quic-go/quic-go to 0.57.0 or later.

## Is CVE-2025-64702 being exploited?

There is no known exploitation of CVE-2025-64702 in the wild and no public exploit code.

Public exploit code:

- CVE-2025-64702, CVE-2026-12523, CVE-2025-13945 (github_poc): https://github.com/HORKimhab/CVE-2025-64702-more

## Other vulnerabilities in quic-go

- [CVE-2023-46239](https://insights.sbomify.com/CVE-2023-46239/): quic-go vulnerable to pointer dereference that can lead to panic (high 7.5)
- [CVE-2022-30591](https://insights.sbomify.com/CVE-2022-30591/): Denial of service in n/a (high 7.5)
- [CVE-2023-49295](https://insights.sbomify.com/CVE-2023-49295/): quic-go's path validation mechanism can cause denial of service (medium 6.4)
- [CVE-2026-40898](https://insights.sbomify.com/CVE-2026-40898/): quic-go: HTTP/3 QPACK Trailer Expansion Memory Exhaustion (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64702 and fix it if it is affected.

What it is: CVE-2025-64702 is a medium-severity denial of service vulnerability in quic-go, published on 11 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64702 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/quic-go/quic-go (Go): affected all versions; fixed in 0.57.0
- github.com/quic-go/quic-go (Go): affected all versions; fixed in 0.57.0
- github.com/quic-go/quic-go (Go): affected all versions; fixed in 0.57.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64702/ (Markdown: https://insights.sbomify.com/CVE-2025-64702/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64702
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64702
- OSV: https://osv.dev/vulnerability/CVE-2025-64702

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64702/
Summaries are generated and may contain mistakes; the official description above is the record.
