# CVE-2025-64708: authentik invitation expiry is delayed by at least 5 minutes

> Attackers can use expired invitations for up to five minutes due to delayed cleanup, bypassing intended access controls in authentik.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2025
- **Updated:** 20 Nov 2025
- **Also known as:** BIT-authentik-2025-64708, GHSA-ch7q-53v8-73pc, GO-2025-4136

## What is CVE-2025-64708?

CVE-2025-64708 is a medium-severity vulnerability in goauthentik authentik, published on 19 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

authentik is an open-source Identity Provider. Prior to versions 2025.8.5 and 2025.10.2, in previous authentik versions, invitations were considered valid regardless if they are expired or not, thus relying on background tasks to clean up expired ones. In a normal scenario this can take up to 5 minutes because the cleanup of expired objects is scheduled to run every 5 minutes. However, with a large amount of tasks in the backlog, this might take longer. authentik versions 2025.8.5 and 2025.10.2 fix this issue. A workaround involves creating a policy that explicitly checks whether the invitation is still valid, and then bind it to the invitation stage on the invitation flow, and denying access if the invitation is not valid.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-64708?

4 open source packages ship an affected version, including goauthentik.io and authentik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `goauthentik.io` | Go | All versions | None |
| `goauthentik.io` | Go | All versions | 0.0.0-20251119135424-6672e6aaa41e |
| `goauthentik.io` | Go | All versions | 0.0.0-20251119135424-6672e6aaa41e |
| `authentik` | Bitnami | All versions | 0.0.0-20251119135424-6672e6aaa41e, 2025.8.5, 2025.10.2 |

Products: Goauthentik Authentik.

## How do I fix CVE-2025-64708?

Upgrade goauthentik.io to 0.0.0-20251119135424-6672e6aaa41e or later.

## Is CVE-2025-64708 being exploited?

There is no known exploitation of CVE-2025-64708 in the wild and no public exploit code.

## Other vulnerabilities in goauthentik authentik

- [CVE-2026-49448](https://insights.sbomify.com/CVE-2026-49448/): authentik: SourceStage bypass via empty POST (critical 9.8)
- [CVE-2023-46249](https://insights.sbomify.com/CVE-2023-46249/): authentik potential installation takeover when default admin user is deleted (critical 9.7)
- [CVE-2022-23555](https://insights.sbomify.com/CVE-2022-23555/): authentik vulnerable to Improper Authentication via invitation URL token reuse (critical 9.4)
- [CVE-2026-42849](https://insights.sbomify.com/CVE-2026-42849/): authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover (critical 9.3)
- [CVE-2026-25227](https://insights.sbomify.com/CVE-2026-25227/): authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64708 and fix it if it is affected.

What it is: CVE-2025-64708 is a medium-severity vulnerability in goauthentik authentik, published on 19 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64708 in the wild and no public exploit code.

Affected packages and fixed versions:
- goauthentik.io (Go): affected all versions; no fix listed
- goauthentik.io (Go): affected all versions; fixed in 0.0.0-20251119135424-6672e6aaa41e
- goauthentik.io (Go): affected all versions; fixed in 0.0.0-20251119135424-6672e6aaa41e
- authentik (Bitnami): affected all versions; fixed in 0.0.0-20251119135424-6672e6aaa41e, 2025.8.5, 2025.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64708/ (Markdown: https://insights.sbomify.com/CVE-2025-64708/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64708
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64708
- OSV: https://osv.dev/vulnerability/CVE-2025-64708

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64708/
Summaries are generated and may contain mistakes; the official description above is the record.
