# CVE-2025-64712: Unstructured has Path Traversal via Malicious MSG Attachment that Allows Arbitrary File Write

> Attackers can write or overwrite arbitrary files on the filesystem by processing malicious MSG attachments, affecting users of the unstructured library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 4 Feb 2026
- **Also known as:** GHSA-gm8q-m8mv-jj5m, PYSEC-2026-558

## What is CVE-2025-64712?

CVE-2025-64712 is a critical path traversal vulnerability in Unstructured-IO unstructured, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The unstructured library provides open-source components for ingesting and pre-processing images and text documents, such as PDFs, HTML, Word docs, and many more. Prior to version 0.18.18, a path traversal vulnerability in the partition_msg function allows an attacker to write or overwrite arbitrary files on the filesystem when processing malicious MSG files with attachments. This issue has been patched in version 0.18.18.

Weakness: CWE-73 (External Control of File Name or Path), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-64712?

3 open source packages ship an affected version, including unstructured. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `unstructured` | PyPI | All versions | 0.18.18 |
| `unstructured` | PyPI | All versions | 0.18.18 |
| `unstructured` | PyPI | All versions | 0.18.18 |

Products: Unstructured Unstructured.

## How do I fix CVE-2025-64712?

Upgrade unstructured to 0.18.18 or later.

## Is CVE-2025-64712 being exploited?

There is no known exploitation of CVE-2025-64712 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64712 and fix it if it is affected.

What it is: CVE-2025-64712 is a critical path traversal vulnerability in Unstructured-IO unstructured, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64712 in the wild and no public exploit code.

Affected packages and fixed versions:
- unstructured (PyPI): affected all versions; fixed in 0.18.18
- unstructured (PyPI): affected all versions; fixed in 0.18.18
- unstructured (PyPI): affected all versions; fixed in 0.18.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64712/ (Markdown: https://insights.sbomify.com/CVE-2025-64712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64712
- OSV: https://osv.dev/vulnerability/CVE-2025-64712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64712/
Summaries are generated and may contain mistakes; the official description above is the record.
