CVE-2025-64715 Cilium with misconfigured toGroups in policies can lead to unrestricted egress traffic
Misconfigured Cilium policies referencing non-existent AWS security groups can unintentionally allow unrestricted egress traffic, bypassing intended network restrictions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-64715?
CVE-2025-64715 is a medium-severity vulnerability in cilium, published on 29 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Prior to versions 1.16.17, 1.17.10, and 1.18.4, CiliumNetworkPolicys which use egress.toGroups.aws.securityGroupsIds to reference AWS security group IDs that do not exist or are not attached to any network interface may unintentionally allow broader outbound access than intended by the policy authors. In such cases, the toCIDRset section of the derived policy is not generated, which means outbound traffic may be permitted to more destinations than originally intended. This issue has been patched in versions 1.16.17, 1.17.10, and 1.18.4. There are no workarounds for this issue.
Weakness: CWE-284
Which versions are affected by CVE-2025-64715?
10 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/cilium/cilium Go | All versions | 1.16.17, 1.17.10, 1.18.4 |
github.com/cilium/cilium Go | All versions | 1.16.17 |
github.com/cilium/cilium Go | All versions | 1.16.17 |
github.com/cilium/cilium Go | From 1.17.0 | 1.17.10 |
github.com/cilium/cilium Go | From 1.17.0 | 1.17.10 |
github.com/cilium/cilium Go | From 1.18.0 | 1.18.4 |
4 more packages
github.com/cilium/cilium Go | From 1.18.0 | 1.18.4 |
cilium Bitnami | All versions | 1.16.17, 1.17.10, 1.18.4 |
cilium-operator Bitnami | All versions | 1.16.17, 1.17.10, 1.18.4 |
hubble-relay Bitnami | All versions | 1.16.17, 1.17.10, 1.18.4 |
Products include Cilium Cilium.
How do I fix CVE-2025-64715?
Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.16.17, 1.17.10 or 1.18.4.
Is CVE-2025-64715 being exploited?
There is no known exploitation of CVE-2025-64715 in the wild and no public exploit code.
Other vulnerabilities in cilium
- CVE-2026-49445 Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access
- CVE-2022-29178 Incorrect Default Permissions in Cilium
- CVE-2024-28860 Insecure IPsec transport encryption in Cilium
- CVE-2026-41520 Cillium exposes sensitive information included in the cilium-bugtool debug archive
- CVE-2024-37307 Cilium leaks sensitive information in cilium-bugtool
Sources
Also known as BIT-cilium-2025-64715, BIT-cilium-operator-2025-64715, BIT-hubble-relay-2025-64715, CLEANSTART-2026-EQ27053, CLEANSTART-2026-MX56215, GHSA-38pp-6gcp-rqvm and 13 more.