# CVE-2025-64715: Cilium with misconfigured toGroups in policies can lead to unrestricted egress traffic

> Misconfigured Cilium policies referencing non-existent AWS security groups can unintentionally allow unrestricted egress traffic, bypassing intended network restrictions.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Nov 2025
- **Updated:** 1 Dec 2025
- **Also known as:** BIT-cilium-2025-64715, BIT-cilium-operator-2025-64715, BIT-hubble-relay-2025-64715, CLEANSTART-2026-EQ27053, CLEANSTART-2026-MX56215, GHSA-38pp-6gcp-rqvm, GO-2025-4167, MINI-48ww-6vxx-3jcr, MINI-8hvv-9hj9-xj5v, MINI-966p-xj4c-m66v, MINI-9m5x-9644-73wx, MINI-9rff-4342-xm75, MINI-chjw-552p-hqpx, MINI-mprm-mg68-wgm7, MINI-pfc2-qmmp-xp5w, MINI-qjmh-x79w-239x, MINI-qmwm-v282-gqj2, MINI-vcx8-v46r-7c6r, MINI-w88g-92m9-f8mw

## What is CVE-2025-64715?

CVE-2025-64715 is a medium-severity vulnerability in cilium, published on 29 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Prior to versions 1.16.17, 1.17.10, and 1.18.4, CiliumNetworkPolicys which use egress.toGroups.aws.securityGroupsIds to reference AWS security group IDs that do not exist or are not attached to any network interface may unintentionally allow broader outbound access than intended by the policy authors. In such cases, the toCIDRset section of the derived policy is not generated, which means outbound traffic may be permitted to more destinations than originally intended. This issue has been patched in versions 1.16.17, 1.17.10, and 1.18.4. There are no workarounds for this issue.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-64715?

10 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | All versions | 1.16.17, 1.17.10, 1.18.4 |
| `github.com/cilium/cilium` | Go | All versions | 1.16.17 |
| `github.com/cilium/cilium` | Go | All versions | 1.16.17 |
| `github.com/cilium/cilium` | Go | From 1.17.0 | 1.17.10 |
| `github.com/cilium/cilium` | Go | From 1.17.0 | 1.17.10 |
| `github.com/cilium/cilium` | Go | From 1.18.0 | 1.18.4 |
| `github.com/cilium/cilium` | Go | From 1.18.0 | 1.18.4 |
| `cilium` | Bitnami | All versions | 1.16.17, 1.17.10, 1.18.4 |
| `cilium-operator` | Bitnami | All versions | 1.16.17, 1.17.10, 1.18.4 |
| `hubble-relay` | Bitnami | All versions | 1.16.17, 1.17.10, 1.18.4 |

Products: Cilium Cilium.

## How do I fix CVE-2025-64715?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.16.17, 1.17.10 or 1.18.4.

## Is CVE-2025-64715 being exploited?

There is no known exploitation of CVE-2025-64715 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64715 and fix it if it is affected.

What it is: CVE-2025-64715 is a medium-severity vulnerability in cilium, published on 29 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64715 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.16.17, 1.17.10, 1.18.4
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.16.17
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.16.17
- github.com/cilium/cilium (Go): affected from 1.17.0; fixed in 1.17.10
- github.com/cilium/cilium (Go): affected from 1.17.0; fixed in 1.17.10
- github.com/cilium/cilium (Go): affected from 1.18.0; fixed in 1.18.4
- github.com/cilium/cilium (Go): affected from 1.18.0; fixed in 1.18.4
- cilium (Bitnami): affected all versions; fixed in 1.16.17, 1.17.10, 1.18.4
- cilium-operator (Bitnami): affected all versions; fixed in 1.16.17, 1.17.10, 1.18.4
- hubble-relay (Bitnami): affected all versions; fixed in 1.16.17, 1.17.10, 1.18.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64715/ (Markdown: https://insights.sbomify.com/CVE-2025-64715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64715
- OSV: https://osv.dev/vulnerability/CVE-2025-64715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64715/
Summaries are generated and may contain mistakes; the official description above is the record.
