CVE-2025-64717 ZITADEL vulnerable to Account Takeover with deactivated Instance IdP

High 7.4 Published Updated

Attackers can take over accounts by exploiting a flaw that ignores disabled identity provider settings during user auto-linking.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-64717?

CVE-2025-64717 is a high-severity authentication bypass vulnerability in zitadel, published on 13 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

ZITADEL is an open source identity management platform. Starting in version 2.50.0 and prior to versions 2.71.19, 3.4.4, and 4.6.6, a vulnerability in ZITADEL's federation process allowed auto-linking users from external identity providers to existing users in ZITADEL even if the corresponding IdP was not active or if the organization did not allow federated authentication. This vulnerability stems from the platform's failure to correctly check or enforce an organization's specific security settings during the authentication flow. An Organization Administrator can explicitly disable an IdP or disallow federation, but this setting was not being honored during the auto-linking process. This allowed an unauthenticated attacker to initiate a login using an IdP that should have been disabled for that organization. The platform would incorrectly validate the login and, based on a matching criteria, link the attacker's external identity to an existing internal user account. This may result in a full Account Takeover, bypassing the organization's mandated security controls. Note that accounts with MFA enabled can not be taken over by this attack. Also note that only IdPs create on an instance level would allow this to work. IdPs registered on another organization would always be denied in the (auto-)linking process. Versions 4.6.6, 3.4.4, and 2.71.19 resolve the issue by correctly validating the organization's login policy before auto-linking an external user. No known workarounds are available aside from upgrading.

Weakness: CWE-287

Which versions are affected by CVE-2025-64717?

9 open source packages ship an affected version, including github.com/zitadel/zitadel. It affects 1 product.

PackageAffectedFixed in
github.com/zitadel/zitadel GoFrom 1.80.0-v2.20.0.20240403060621-5b3946b67ef61.80.0-v2.20.0.20251112124840-33c51deb2040
github.com/zitadel/zitadel GoFrom 1.80.0-v2.20.0.20240403060621-5b3946b67ef61.80.0-v2.20.0.20251112124840-33c51deb2040
github.com/zitadel/zitadel GoFrom 1.80.0-v2.20.0.20240403060621-5b3946b67ef61.80.0-v2.20.0.20251112124840-33c51deb2040
github.com/zitadel/zitadel GoFrom 2.50.02.71.19
github.com/zitadel/zitadel GoFrom 2.50.02.71.19
github.com/zitadel/zitadel GoFrom 3.0.0-rc.13.4.4
3 more packages
github.com/zitadel/zitadel GoFrom 3.0.0-rc.13.4.4
github.com/zitadel/zitadel GoFrom 4.0.0-rc.14.6.6
github.com/zitadel/zitadel GoFrom 4.0.0-rc.14.6.6

Products include Zitadel Zitadel.

How do I fix CVE-2025-64717?

Upgrade github.com/zitadel/zitadel to a fixed version for your release line: 1.80.0-v2.20.0.20251112124840-33c51deb2040, 2.71.19, 3.4.4 or 4.6.6.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-64717 being exploited?

There is no known exploitation of CVE-2025-64717 in the wild and no public exploit code.

Sources

Also known as GHSA-j4g7-v4m4-77px, GO-2025-4124.

Is CVE-2025-64717 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free