# CVE-2025-64718: js-yaml has prototype pollution in merge (<<)

> Attackers can pollute object prototypes when parsing untrusted YAML, potentially leading to code execution or privilege escalation in Node.js applications.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Nov 2025
- **Updated:** 29 Jan 2026
- **Also known as:** CLEANSTART-2026-AO87470, CLEANSTART-2026-GV78775, CLSA-2026-1773965915, DEBIAN-CVE-2025-64718, ECHO-5d95-5ad2-512c, GHSA-mh29-5h37-fv8m, MINI-4w3g-4w2v-9524, MINI-5v8w-pgcp-2wq4, MINI-5w96-f692-8x63, MINI-6v2c-wfc7-5vg2, MINI-8jwx-793q-2wmj, MINI-8phf-2hw9-qvv8, MINI-cfgf-wxx6-7gf5, MINI-chr3-jmjh-fvmf, MINI-gcw7-2c9r-9gww, MINI-hr46-j729-h59x, MINI-j8q6-vwm3-qvqm, MINI-mp2j-7j26-62fq, MINI-q9qj-46c9-4grw, MINI-x2g7-j7f6-5rx9, MINI-x3vh-jxvc-chv9, MINI-x3vj-cmxh-ggc5, MINI-x9ww-qh25-h7g3, MINI-xwm2-xhhw-2w6h, OESA-2026-1166, OESA-2026-1167, OESA-2026-1168, OESA-2026-1169, OESA-2026-1170, OESA-2026-1171, ROOT-APP-NPM-CVE-2025-64718, SUSE-SU-2026:20170-1, SUSE-SU-2026:20182-1, UBUNTU-CVE-2025-64718, openSUSE-SU-2026:10036-1, openSUSE-SU-2026:20117-1

## What is CVE-2025-64718?

CVE-2025-64718 is a medium-severity vulnerability in nodeca js-yaml, published on 13 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

js-yaml is a JavaScript YAML parser and dumper. In js-yaml before 4.1.1 and 3.14.2, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution (`__proto__`). All users who parse untrusted yaml documents may be impacted. The problem is patched in js-yaml 4.1.1 and 3.14.2. Users can protect against this kind of attack on the server by using `node --disable-proto=delete` or `deno` (in Deno, pollution protection is on by default).

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-64718?

4 open source packages ship an affected version, including js-yaml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `js-yaml` | npm | All versions | 3.14.2 |
| `js-yaml` | npm | All versions | 3.14.2 |
| `js-yaml` | npm | From 4.0.0 | 4.1.1 |
| `js-yaml` | npm | From 4.0.0 | 4.1.1 |
| `cockpit-subscriptions` | SUSE:Linux Enterprise Server 16.0 | All versions | 12.1-160000.1.1 |
| `cockpit-subscriptions` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 12.1-160000.1.1 |
| `cockpit-subscriptions` | SUSE:Linux Micro 6.2 | All versions | 12.1-160000.1.1 |
| `cockpit-subscriptions` | openSUSE:Leap 16.0 | All versions | 12.1-160000.1.1 |
| `cockpit-repos` | openSUSE:Tumbleweed | All versions | 4.6-1.1 |

Products: Nodeca Js-Yaml.

## How do I fix CVE-2025-64718?

Upgrade js-yaml to a fixed version for your release line: 3.14.2 or 4.1.1.

## Is CVE-2025-64718 being exploited?

There is no known exploitation of CVE-2025-64718 in the wild and no public exploit code.

## Other vulnerabilities in nodeca js-yaml

- [CVE-2026-59869](https://insights.sbomify.com/CVE-2026-59869/): js-yaml: YAML merge-key chains can force quadratic CPU consumption (high 7.5)
- [CVE-2026-59870](https://insights.sbomify.com/CVE-2026-59870/): js-yaml quadratic-complexity denial of service via YAML11_SCHEMA !!omap parsing (high 7.5)
- [CVE-2013-4660](https://insights.sbomify.com/CVE-2013-4660/): Deserialization Code Execution in js-yaml (medium 6.8)
- [CVE-2026-59868](https://insights.sbomify.com/CVE-2026-59868/): js-yaml: YAML merge-key chains can force quadratic CPU consumption (medium 5.3)
- [CVE-2026-53550](https://insights.sbomify.com/CVE-2026-53550/): js-yaml: Quadratic-complexity DoS in merge key handling via repeated aliases (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64718 and fix it if it is affected.

What it is: CVE-2025-64718 is a medium-severity vulnerability in nodeca js-yaml, published on 13 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64718 in the wild and no public exploit code.

Affected packages and fixed versions:
- js-yaml (npm): affected all versions; fixed in 3.14.2
- js-yaml (npm): affected all versions; fixed in 3.14.2
- js-yaml (npm): affected from 4.0.0; fixed in 4.1.1
- js-yaml (npm): affected from 4.0.0; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64718/ (Markdown: https://insights.sbomify.com/CVE-2025-64718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64718
- OSV: https://osv.dev/vulnerability/CVE-2025-64718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64718/
Summaries are generated and may contain mistakes; the official description above is the record.
