{"answers":{"affected":"3 open source packages ship an affected version, including gogs.io/gogs.","exploited":"There is no known exploitation of CVE-2025-64719 in the wild and no public exploit code.","fix":"Upgrade gogs.io/gogs to 0.14.3 or later.","what":"CVE-2025-64719 is a medium-severity denial of service vulnerability in gogs, published on 24 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-64719 and fix it if it is affected.\n\nWhat it is: CVE-2025-64719 is a medium-severity denial of service vulnerability in gogs, published on 24 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-64719 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gogs.io/gogs (Go): affected all versions; no fix listed\n- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3\n- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-64719/ (Markdown: https://insights.sbomify.com/CVE-2025-64719/index.md)","id":"CVE-2025-64719","markdown":"https://insights.sbomify.com/CVE-2025-64719/index.md","name":"CVE-2025-64719","record":{"aliases":["GHSA-3qq3-668m-v9mj","GO-2026-5098"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Self-hosted Git service","requires_auth":"high_privilege","summary":"A malicious user can trigger a denial of service in Gogs by creating files that cause HTTP 500 errors on repository or wiki listing pages.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Gogs is an open source self-hosted Git service. Prior to 0.14.3, a malicious user with rights to create a new file on a repository or wiki page can trigger a denial of service condition in which the pages containing the listing of files will return HTTP error 500 and render the web interface unusable for the repository or wiki. The issue is present in file internal/route/repo/wiki.go and internal/route/repo/view.go where the pages try to recover commit information. If errors are returned while recovering commit information, the page will return a 500 error and stop rendering, resulting in a denial of service. This vulnerability is fixed in 0.14.3.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Gogs: Denial of Service in repository/wiki file listing web pages","id":"CVE-2025-64719","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"LIBPNG is vulnerable to a buffer overflow in `png_image_read_composite` via incorrect palette premultiplication","id":"CVE-2025-64720"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":"pkg:golang/gogs.io/gogs","source":"GO-2026-5098"},{"ecosystem":"Go","fixed":["0.14.3"],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":null,"source":"GHSA-3qq3-668m-v9mj"},{"ecosystem":"Go","fixed":["0.14.3"],"introduced":["0"],"last_affected":[],"package":"gogs.io/gogs","purl":"pkg:golang/gogs.io/gogs","source":"GHSA-3qq3-668m-v9mj"}],"prev":{"headline":"js-yaml has prototype pollution in merge (\u003c\u003c)","id":"CVE-2025-64718"},"products":["gogs"],"published":"2026-06-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-25","vendors":["gogs"]},"summary":"A malicious user can trigger a denial of service in Gogs by creating files that cause HTTP 500 errors on repository or wiki listing pages.","url":"https://insights.sbomify.com/CVE-2025-64719/"}