# CVE-2025-64720: LIBPNG is vulnerable to a buffer overflow in `png_image_read_composite` via incorrect palette premultiplication

> An out-of-bounds read in libpng allows attackers to cause denial of service or disclose memory when processing specific palette images.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Nov 2025
- **Updated:** 25 Nov 2025
- **Also known as:** A-463995203, ALPINE-CVE-2025-64720, ASB-A-463995203, AZL-70847, AZL-70868, AZL-70883, AZL-70888, AZL-70921, AZL-70928, AZL-70972, BELL-CVE-2025-64720, CLSA-2026-1768909961, CLSA-2026-1768911013, DEBIAN-CVE-2025-64720, ECHO-ad7d-93e1-b804, GHSA-hfc7-ph9c-wcww, JLSEC-2025-330, MINI-x2fw-4f8q-cp73, RHSA-2026:0251, ROOT-OS-ALPINE-315-CVE-2025-64720, SUSE-SU-2026:2619-1

## What is CVE-2025-64720?

CVE-2025-64720 is a high-severity memory corruption vulnerability in Libpng Libpng, published on 24 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From version 1.6.0 to before 1.6.51, an out-of-bounds read vulnerability exists in png_image_read_composite when processing palette images with PNG_FLAG_OPTIMIZE_ALPHA enabled. The palette compositing code in png_init_read_transformations incorrectly applies background compositing during premultiplication, violating the invariant component ≤ alpha × 257 required by the simplified PNG API. This issue has been patched in version 1.6.51.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-64720?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpng` | Red Hat:rhel_els:7 | All versions | 2:1.5.13-8.el7_9.1 |
| `libpng-debuginfo` | Red Hat:rhel_els:7 | All versions | 2:1.5.13-8.el7_9.1 |
| `libpng-devel` | Red Hat:rhel_els:7 | All versions | 2:1.5.13-8.el7_9.1 |
| `libpng-static` | Red Hat:rhel_els:7 | All versions | 2:1.5.13-8.el7_9.1 |
| `libpng15` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 1.5.30-10.13.1 |

Products: Libpng Libpng.

## How do I fix CVE-2025-64720?

Upgrade to a fixed version.

## Is CVE-2025-64720 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64720 exists.

Public exploit code:

- https://github.com/dantsco/CVE-2025-64720-PoC (github_poc): https://github.com/dantsco/CVE-2025-64720-PoC

## Other vulnerabilities in Libpng Libpng

- [CVE-2017-12652](https://insights.sbomify.com/CVE-2017-12652/): Denial of service in n/a (critical 9.8)
- [CVE-2018-14550](https://insights.sbomify.com/CVE-2018-14550/): Out-of-bounds write in libpng (high 8.8)
- [CVE-2026-25646](https://insights.sbomify.com/CVE-2026-25646/): LIBPNG has a heap buffer overflow in png_set_quantize (high 8.3)
- [CVE-2026-33636](https://insights.sbomify.com/CVE-2026-33636/): LIBPNG has ARM NEON Palette Expansion Out-of-Bounds Read on AArch64 (high 7.6)
- [CVE-2026-33416](https://insights.sbomify.com/CVE-2026-33416/): LIBPNG has use-after-free via pointer aliasing in `png_set_tRNS` and `png_set_PLTE` (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64720 and fix it if it is affected.

What it is: CVE-2025-64720 is a high-severity memory corruption vulnerability in Libpng Libpng, published on 24 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64720 exists.

Affected product: Libpng Libpng. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64720/ (Markdown: https://insights.sbomify.com/CVE-2025-64720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64720
- OSV: https://osv.dev/vulnerability/CVE-2025-64720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64720/
Summaries are generated and may contain mistakes; the official description above is the record.
