# CVE-2025-64725: Weblate has improper validation upon invitation acceptance

> Attackers can accept invitations opened by other users, potentially gaining unauthorized access to projects or accounts.

- **Severity:** Low 1.0 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Dec 2025
- **Updated:** 15 Dec 2025
- **Also known as:** GHSA-m6hq-f4w9-qrjj, PYSEC-2026-2042

## What is CVE-2025-64725?

CVE-2025-64725 is a low-severity vulnerability in WeblateOrg weblate, published on 15 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Weblate is a web based localization tool. In versions prior to 5.15, it was possible to accept an invitation opened by a different user. Version 5.15. contains a patch. As a workaround, avoid leaving one's Weblate sessions with an invitation opened unattended.

Weakness: CWE-286 (Incorrect User Management)

## Which versions are affected by CVE-2025-64725?

3 open source packages ship an affected version, including weblate and Weblate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | PyPI | All versions | 5.15 |
| `weblate` | PyPI | All versions | 5.15 |
| `Weblate` | PyPI | All versions | 5.15 |

Products: Weblate Weblate.

## How do I fix CVE-2025-64725?

Upgrade weblate to 5.15 or later.

## Is CVE-2025-64725 being exploited?

There is no known exploitation of CVE-2025-64725 in the wild and no public exploit code.

## Other vulnerabilities in WeblateOrg weblate

- [CVE-2025-68398](https://insights.sbomify.com/CVE-2025-68398/): Weblate has git config file overwrite vulnerability that leads to remote code execution (critical 9.1)
- [CVE-2026-34393](https://insights.sbomify.com/CVE-2026-34393/): Weblate: Privilege escalation in the user API endpoint (high 8.8)
- [CVE-2026-33435](https://insights.sbomify.com/CVE-2026-33435/): Weblate: Remote code execution during backup restoration (high 8.1)
- [CVE-2026-34242](https://insights.sbomify.com/CVE-2026-34242/): Weblate: Arbitrary File Read via Symlink (high 7.7)
- [CVE-2025-68279](https://insights.sbomify.com/CVE-2025-68279/): Weblate has an arbitrary file read via symbolic links (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64725 and fix it if it is affected.

What it is: CVE-2025-64725 is a low-severity vulnerability in WeblateOrg weblate, published on 15 Dec 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-64725 in the wild and no public exploit code.

Affected packages and fixed versions:
- weblate (PyPI): affected all versions; fixed in 5.15
- weblate (PyPI): affected all versions; fixed in 5.15
- Weblate (PyPI): affected all versions; fixed in 5.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64725/ (Markdown: https://insights.sbomify.com/CVE-2025-64725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64725
- OSV: https://osv.dev/vulnerability/CVE-2025-64725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64725/
Summaries are generated and may contain mistakes; the official description above is the record.
