# CVE-2025-64746: Directus has Improper Permission Handling on Deleted Fields

> Attackers or unauthorized users may access or modify data due to stale permissions when deleted field names are reused in Directus.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Nov 2025
- **Updated:** 13 Nov 2025
- **Also known as:** GHSA-9x5g-62gj-wqf2

## What is CVE-2025-64746?

CVE-2025-64746 is a medium-severity missing authorization vulnerability in Monospace Directus, published on 13 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Directus is a real-time API and App dashboard for managing SQL database content. Prior to version 11.13.0, Directus does not properly clean up field-level permissions when a field is deleted. When a field is removed from a collection, its reference in the permissions table remains intact. This stale reference creates a security gap: if another field is later created using the same name, it inherits the outdated permission entry. This behavior can unintentionally grant roles access to data they should not be able to read or modify. The issue is particularly risky in multi-tenant or production environments, where administrators may reuse field names, assuming old permissions have been fully cleared. Version 11.13.0 fixes the issue.

Weakness: CWE-863 (Incorrect Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-64746?

2 open source packages ship an affected version, including directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `directus` | npm | All versions | 11.13.0 |
| `directus` | npm | All versions | 11.13.0 |

Products: Monospace Directus.

## How do I fix CVE-2025-64746?

Upgrade directus to 11.13.0 or later.

## Is CVE-2025-64746 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64746 exists.

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64746 and fix it if it is affected.

What it is: CVE-2025-64746 is a medium-severity missing authorization vulnerability in Monospace Directus, published on 13 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-64746 exists.

Affected packages and fixed versions:
- directus (npm): affected all versions; fixed in 11.13.0
- directus (npm): affected all versions; fixed in 11.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64746/ (Markdown: https://insights.sbomify.com/CVE-2025-64746/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64746
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64746
- OSV: https://osv.dev/vulnerability/CVE-2025-64746

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64746/
Summaries are generated and may contain mistakes; the official description above is the record.
