# CVE-2025-64749: Directus Vulnerable to Information Leakage in Existing Collections

> Attackers can enumerate existing collections via differing error messages in the Directus REST API, leaking metadata to unauthorized users.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Nov 2025
- **Updated:** 14 Nov 2025
- **Also known as:** GHSA-cph6-524f-3hgr

## What is CVE-2025-64749?

CVE-2025-64749 is a medium-severity vulnerability in Monospace Directus, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Directus is a real-time API and App dashboard for managing SQL database content. An observable difference in error messaging was found in the Directus REST API in versions of Directus prior to version 11.13.0. The `/items/{collection}` API returns different error messages for two cases: when a user tries to access an existing collection which they are not authorized to access, and when user tries to access a non-existing collection. The two differing error messages leak the existence of collections to users which are not authorized to access these collections. Version 11.13.0 fixes the issue.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information), CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2025-64749?

4 open source packages ship an affected version, including @directus/api and directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@directus/api` | npm | All versions | 32.0.0 |
| `@directus/api` | npm | All versions | 32.0.0 |
| `directus` | npm | All versions | 11.13.0 |
| `directus` | npm | All versions | 11.13.0 |

Products: Monospace Directus.

## How do I fix CVE-2025-64749?

Upgrade @directus/api to 32.0.0 or later.

## Is CVE-2025-64749 being exploited?

There is no known exploitation of CVE-2025-64749 in the wild and no public exploit code.

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-64749 and fix it if it is affected.

What it is: CVE-2025-64749 is a medium-severity vulnerability in Monospace Directus, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-64749 in the wild and no public exploit code.

Affected packages and fixed versions:
- @directus/api (npm): affected all versions; fixed in 32.0.0
- @directus/api (npm): affected all versions; fixed in 32.0.0
- directus (npm): affected all versions; fixed in 11.13.0
- directus (npm): affected all versions; fixed in 11.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-64749/ (Markdown: https://insights.sbomify.com/CVE-2025-64749/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-64749
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-64749
- OSV: https://osv.dev/vulnerability/CVE-2025-64749

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-64749/
Summaries are generated and may contain mistakes; the official description above is the record.
